Bug 166942 - Sound doesn't work since glibc upgrade
Sound doesn't work since glibc upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-28 09:10 EDT by euphgeek
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 21:53:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace play /usr/share/sounds/KDE_Beep_Beep.wav (11.25 KB, text/plain)
2005-08-28 21:51 EDT, euphgeek
no flags Details

  None (edit)
Description euphgeek 2005-08-28 09:10:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Ever since I updated glibc using yum, I have been unable to get any sound from my speakers.  I have tried restarting the sound server (artsd) and I have even tried issuing the command "cat <soundfile> >/dev/dsp" but nothing ever happens.  When I issue the "play" command from the command line, it acts like it's playing the file but no sound comes out.  There are no error messages and my speakers are on and plugged in to the correct jack.

Version-Release number of selected component (if applicable):
glibc-2.3.5-10.3

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to glibc-2.3.5-10.3
2. Restart X server
3. Try to play a sound file
  

Actual Results:  No sound comes out of my speakers

Expected Results:  I should hear sounds coming out of my speakers.

Additional info:
Comment 1 Ulrich Drepper 2005-08-28 16:04:11 EDT
This cannot possibly have anything to do with glibc.  Run strace on the programs
in question to see if you see a failure and where.
Comment 2 euphgeek 2005-08-28 21:51:51 EDT
Created attachment 118200 [details]
strace play /usr/share/sounds/KDE_Beep_Beep.wav

Here is the output of strace.
Comment 3 Jakub Jelinek 2005-08-29 03:17:35 EDT
That strace dump is useless, as play is forking, invoking another program and
that hasn't been traced.
If you really want to claim this has anything to do with glibc, you need to
prove it first.  I.e.:
1) go back to glibc-2.3.5-10 (or whatever other glibc you claim worked),
   but only downgrade glibc (and its aux subpackages), nothing else
2) strace -f -o working play /usr/share/sounds/KDE_Beep_Beep.wav
   (as long as it works in that case)
3) upgrade to glibc-2.3.5-10.3 (and its aux subpackages), but no other packages
4) strace -f -o nonworking play /usr/share/sounds/KDE_Beep_Beep.wav
   (as long as it doesn't work in that case)
Comment 4 euphgeek 2005-08-29 21:53:34 EDT
Never mind, I figured it out.

Note You need to log in before you can comment on or make changes to this bug.