Bug 166944 - Bad: Can't login after audit update
Bad: Can't login after audit update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Grubb
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-28 11:34 EDT by Aaron Murray
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-01 08:25:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Murray 2005-08-28 11:34:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; en) Opera 8.02

Description of problem:
Used Yumex to update several modules, including the kernel and a few other 
related items... one of which was audit.  After rebooting, the greeter page 
(login) looped after entering username - ie enter username, screen went blank 
then about 30 secs later it would loop back to the login screen.

I removed the new kernel-2.6.12-1.1398.fc4, but it made no difference.
Checked /var/log/yum.log for any other modules that might affect it.
ran rpm -e audit-1.0.3-1.fc4  (wasn't sure if this would revert to previous 
audit version or delete entirely... so I then used install cd's and did an 
upgrade install (to make sure it was good)
Voila - I could log in (had tried the install cd's without removing audit first 
to no effect)

Version-Release number of selected component (if applicable):
audit-1.0.3-1.fc4

How reproducible:
Didn't try

Steps to Reproduce:
1.Select and install audit in Yumex
2.Reboot
3.Type Username at login screen (gdm)
  

Actual Results:  Blank screen, then blue screen with a cursor, then login screen again.


Expected Results:  Should have asked for password

Additional info:

Running Gnome desktop, KDE not installed
Comp is i586.. Amd K6-2 400 MHz 

Severity - high - couldn't login except as single or through rescueCD
Comment 1 Steve Grubb 2005-08-29 08:53:37 EDT
There are several interelated issues that I need to sort out. What kernel are
you running? Did you compile it yourself? What version of gdm & pam?

When you are in the configuration that won't let you log in, can you boot to run
level 3 and try to log in? Do you get the same results?

Was there anything in /var/log/messages ?

If you change the pam config of loginuid.so for login and gdm from required to
optional. Does that let you in?

Thanks
Comment 2 Aaron Murray 2005-08-29 11:02:06 EDT
The kernel I'm running is kernel-2.6.11-1.1369-FC4.  When I did the update
though, I did upgrade this to 2.6.12-1.1398-fc4.  The original kernel was from
the ISO cd's of fc4. I have compiled nothing myself.  This was a new
installation on a separate drive to anything else.  I am new to linux though
thankfully I did a course on unix about 8 years ago.  Someone in IRC told me to
try booting as Single from the grub... I was able to boot that way and running
'login' worked fine.  I didn't try the level 3 and am not sure what it is.

var/log/messages had some interesting bits:

Normal Boot:
==================
Aug 27 13:28:26 localhost gdm(pam_unix)[2452]: session opened for user Aaron by
(uid=0)
Aug 27 13:28:30 localhost gconfd (Aaron-2607): starting (version 2.10.0), pid
2607 user 'Aaron'

Boot After Updates:
=====================
Aug 28 08:56:27 localhost gdmgreeter[2496]: Unexpected greeter command received:
'^D'
Aug 28 08:56:28 localhost kernel: audit(:309029): major=252 name_count=0:
freeing multiple contexts (1)
Aug 28 08:56:28 localhost kernel: audit(:281927): major=113 name_count=0:
freeing multiple contexts (2)
Aug 28 08:57:03 localhost gdm(pam_unix)[2528]: check pass; user unknown
Aug 28 08:57:03 localhost gdm(pam_unix)[2528]: authentication failure; logname=
uid=0 euid=0 tty=:0 ruser= rhost= 
Aug 28 08:57:07 localhost gdm-binary[2528]: Couldn't authenticate user
======================

After a normal login, the screen flickers black, then blue with a mouse cursor
central... After updating, it did the same then would go back to the login
(greeter) screen.  The section above was repeated in messages till I gave up and
rebooted.

I don't know about the loginuid.so.  I'm reluctant to test it again.

gdm wasn't updated, neither was pam... I didn't select all in yumex (first time
I'd used it)
gdm-2.6.0.8-16
pam-0.79-8
the above are from rpm -q [name] (I assume that's how you get the info)

I initially thought the kernel may have been at fault so I uninstalled
kernel-2.6.12-1.1398-fc4, but it still did exactly the same thing.

Eventually I found the /var/log/yum.log to see what I had installed.
audit seemed the most likely culprit so I uninstalled it (rpm -e
audit-1.0.3-1.fc4) and audit-libs.  Other things installed were libraries like
glibc etc.  I wasn't sure if this would rollback to the previous version or
leave a gaping hole, so I got out my FC4 cd's and ran the install and selected
upgrade.

Next boot everything worked perfectly.

Would there have been other dependencies that I didn't update?
Comment 3 Steve Grubb 2005-08-31 09:46:30 EDT
Looking at the above, I think your pam package is out of date. The current
version is pam-0.79-9.4. There were several items fixed in it to make it
co-exist with the audit system better. I would upgrade pam and then see if you
still have a problem.
Comment 4 Aaron Murray 2005-08-31 23:08:17 EDT
I think that must be it.  I discovered after uninstalling audit, that it hadn't 
re-installed as I'd expected.
I reinstalled audit-1.0.3-1.fc4 then installed all updates from updates-released 
repository.

pam and gdm were included in that.

Restarted and all boots up and logs in as normal...  In future I'll install all 
updates rather than selecting some.

Cheers

Note You need to log in before you can comment on or make changes to this bug.