Bug 1669463 - [SDN-131] Should have a list of special namespaces which would ignore the defaultNetworks
Summary: [SDN-131] Should have a list of special namespaces which would ignore the def...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Tomofumi Hayashi
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-25 11:14 UTC by Meng Bo
Modified: 2019-06-04 10:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:22 UTC

Description Meng Bo 2019-01-25 11:14:37 UTC
Description of problem:
We are using a hardcoded namespace `kube-system` which will ignore the setting in defaultNetworks for multus.

This is not a problem in kubernetes cluster or OCP 3.x cluster, since all the critical service are deployed under kube-system. 

But for OCP 4.0, there is a lot of system services which are running in different namespaces.
Eg, 
the coredns in running in openshift-dns namespace

We should change the hardcoded kube-system to a configurable list.


Version-Release number of selected component (if applicable):
4.0

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
The pod will ignore the defaultNetworks crd in kube-system only.

Expected results:
As we discussed in PR https://github.com/intel/multus-cni/pull/203
The coredns service is not running in kube-system now.

We should update the kube-system namespace or even better have a configurable list.

Additional info:

Comment 1 Tomofumi Hayashi 2019-01-29 09:38:53 UTC
https://github.com/intel/multus-cni/issues/253

Comment 2 Casey Callendrello 2019-03-06 14:35:09 UTC
Is this downstreamed? can this be marked as MODIFIED?

Comment 3 Tomofumi Hayashi 2019-03-06 14:57:21 UTC
Casay,

Thank you for your reminder!
Verified that the fix is in downstream, https://github.com/openshift/multus-cni/commit/73e10fb99993963aa73125aeffffa685776e3090 so changed to MODIFIED.

Comment 6 Meng Bo 2019-03-18 10:13:39 UTC
Tested on 4.0.0-0.nightly-2019-03-15-063749

The new added parameters systemNamespaces and multusNamespace are both working fine.

Move the bug to verified.

Comment 8 errata-xmlrpc 2019-06-04 10:42:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.