Bug 16695 - Email checks are not strict enough..
Summary: Email checks are not strict enough..
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: Join_Process (Show other bugs)
(Show other bugs)
Version: current
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tom Lancaster
QA Contact: Paul Lindner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-21 21:23 UTC by Paul Lindner
Modified: 2007-04-18 16:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-21 21:24:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Lindner 2000-08-21 21:23:16 UTC
I'm getting a bunch of bounced messages when users enter bad email
addresses.

We should do stricter checking.  Email::Valid supports this.

We need to install Net::DNS, and we need to modify the join callback and
the formmail callback to use the new Email::Valid features..

Comment 1 Paul Lindner 2000-08-21 21:24:22 UTC
Tom, can you have a crack at this.  Should be simple...


Comment 2 Tom Lancaster 2000-08-28 20:32:09 UTC
This is done as requested. The Net::DNS modules are in cvs under lib/
I've implemented the checks by adding the parameter 'mxcheck => 1' to the
Email::Valid->address
call in join/callback.apm.

Please note that I'm not sure how much of a good idea this is, because it
*significantly* slows response time when the user submits.

This is not live yet, just on webdev.


Note You need to log in before you can comment on or make changes to this bug.