Bug 166950 - [kde] ooimpress feezes with insert spreadsheet
[kde] ooimpress feezes with insert spreadsheet
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-28 14:16 EDT by Sammy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.9.128-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-10 05:55:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of stall (9.67 KB, application/octet-stream)
2005-09-06 11:24 EDT, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 50792 None None None Never
OpenOffice.org 51738 None None None Never

  None (edit)
Description Sammy 2005-08-28 14:16:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.2 (like Gecko)

Description of problem:
Almost always (about 90% of the time) pressing the spreadsheet button on the menu 
bar freezes ooimpress. 
 
FYI 

Version-Release number of selected component (if applicable):
openoffice.org-base-1.9.125-4.2.0.fc5

How reproducible:
Sometimes

Steps to Reproduce:
1. start ooimpress 
2. click the spreadsheet button 
3. 
   

Additional info:
Comment 1 Caolan McNamara 2005-08-29 06:33:27 EDT
not able to reproduce this yet, but
http://qa.openoffice.org/issues/show_bug.cgi?id=50792 sounds a little similiar
Comment 2 Caolan McNamara 2005-09-05 09:57:31 EDT
In theory this could be related to rh#167130# where the drawing "undo" stuff has
some possible problems fixed in workspace impress57 which is included in >=
1.9.127-1. Is it still reproducable for you in 1.9.127 ?
Comment 3 Sammy 2005-09-05 11:25:54 EDT
Unfortunately YES.
Comment 4 Caolan McNamara 2005-09-06 03:00:49 EDT
i don't understand how you can have a rawhide devel version with such a
reproducable bug which doesn't appear for me :-(
Comment 5 Caolan McNamara 2005-09-06 05:39:04 EDT
anything non-default about your setup ? e.g. ldap users ? sun java instead of
libgcj ?
Comment 6 Sammy 2005-09-06 09:33:23 EDT
YES. I am using SUN java as packaked by the jpackage project
(http://www.jpackage.org/). I am also using the latest BeanShell and not from
rawhide. With these the Tools-->Macros are working. What is java dependent
in OpenOffice inserting a table? Other than that everything is from rawhide.
Thanks
Comment 7 Caolan McNamara 2005-09-06 09:40:47 EDT
no idea if it's connected, but I can't reproduce the problem.

anything useful from

gdb /usr/lib/openoffice.org/program/soffice.bin
(gdb) handle SIGPWR nostop noprint
(gdb) handle SIGXCPU nostop noprint
(gdb) handle SIG33 nostop noprint
(gdb) run -writer

insert the spreadsheet to make it hang and then when hung, ctrl + c in gdb and

(gdb) thread apply all bt
Comment 8 Sammy 2005-09-06 10:02:11 EDT
When I run it with gdb it is not crashing (tried twice and I am running
"run -impress" not writer").

However, under gdb the environment looks different e.g. colors, fonts etc
do not seem to be the usual gtk2 stuff and more like plain "fixed" old
x-window look.

To make it clear: I am using Impress and hitting the "insert spreadsheet" menu
button to insert a new spreadsheet.
Thanks
Comment 9 Caolan McNamara 2005-09-06 10:07:14 EDT
must be under kde then ?, that might be the missing piece of the puzzle.
Comment 10 Sammy 2005-09-06 10:39:36 EDT
Well, if I remove libvclplug_gtk680li.so the crashes become more seldom.
Comment 11 Caolan McNamara 2005-09-06 11:23:08 EDT
embedded spreadsheet appears, save progress bar does something and then impress
hangs ? I see this under kde.

Comment 12 Caolan McNamara 2005-09-06 11:24:05 EDT
Created attachment 118513 [details]
backtrace of stall
Comment 13 Caolan McNamara 2005-09-07 10:00:46 EDT
have a patch which might resolve this, at least temporarily. Seems like some
mutex deadlock.
Comment 14 Caolan McNamara 2005-09-08 09:37:18 EDT
no, that's not it. Appears to be a selection based issue, deadlock due to
clipboard klipper thing i think. 
Comment 15 Caolan McNamara 2005-09-08 11:11:07 EDT
new patch seems to work, lets give it a spin. building for 1.9.128-2
Comment 16 Caolan McNamara 2005-09-10 05:55:36 EDT
looks good in 1.9.128-2

Note You need to log in before you can comment on or make changes to this bug.