Bug 166957 - Installer can't handle raid parameters when re-using devices
Installer can't handle raid parameters when re-using devices
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-08-28 19:08 EDT by Yves Perrenoud
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-24 17:31:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Yves Perrenoud 2005-08-28 19:08:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
Given a system that already has a root raid device (md0) and a swap raid device (md1), it seems impossible to have anaconda re-use those by passing "raid" and "part" commands in the config file.

Based on the following thread:


I attempted to:

raid / --device md0 --useexisting
raid swap --device md1 --noformat

This was ignored as if I hadn't passed anything in the config, and was prompted to partition by hand.

Then tried this:

part raid.1 --noformat --onpart sda1
part raid.2 --noformat --onpart sdb1
part raid.3 --noformat --onpart sda2
part raid.4 --noformat --onpart sdb2
raid / --fstype ext3 --level=1 --device md0 raid.1 raid.2
raid swap --fstype swap --level=1 --device md1 raid.3 raid.4

This yielded a python exception dialog.

Then I tried all permutations of those scenarios, with or without --useexisting or --noformat, with or without "=" signs betwen options and their parameters, etc... nothing helped, still either ignored or the python exception dialogue.

I ultimately ended up performing the operations by hand through the UI, not perticularly convenient when trying to automate...

Oh, and after performing the operation by hand, I extracted the part and raid parameters that anaconda generated in /root/anaconda-ks.cfg, those yielded the python exception dialogue.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. fire off the install with a ks=... pointing to the config file containing part and/or raid commands

Actual Results:  prompted to manually configure or python exception dialogue

Expected Results:  installer performs install

Additional info:
Comment 1 Jeremy Katz 2005-08-30 14:52:02 EDT
You need something like the second of these two... what is the exact traceback
you got?  Without that, it's pretty difficult to say what went wrong.  
Comment 3 Red Hat Bugzilla 2007-06-11 22:54:56 EDT
requested by Jams Antill

Note You need to log in before you can comment on or make changes to this bug.