This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 166958 - %post should check if info file exists before calling install-info to avoid error when installing with ---excludedocs
%post should check if info file exists before calling install-info to avoid e...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Miloslav Trmač
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-28 19:13 EDT by Albert Strasheim
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.8-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-15 23:29:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Albert Strasheim 2005-08-28 19:13:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
When one installs info (and many other packages) with rpm's --excludedocs switch, the %post script generates an error because /sbin/install-info is called for a file that does not exist (some part of the documentation).

Is --excludedocs something we want to support? If so, should we get all the package maintainers to fix their spec files (some already check for existance of the info files prior to calling install-info)? We could also consider adding some kind of --missing-ok flag to install-info to be used when installing info documents in %post.

I'm thinking that fixing this could be useful for the Kadischi folks. I encountered this problem while trying to make a small Fedora installation to boot from a USB flash disk.

Version-Release number of selected component (if applicable):
info-4.8-4

How reproducible:
Always

Steps to Reproduce:
1. rpm --excludedocs -ivh info
2.
3.
  

Actual Results:  install-info: No such file or directory for /usr/share/info/info-stnd.info.gz
error: %post(info-4.8-4.i386) scriptlet failed, exit status 1

Expected Results:  %post script should complete without error.

Additional info:
Comment 1 Miloslav Trmač 2006-01-15 23:28:53 EST
Fixed in rawhide texinfo-4.8-8.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.