Bug 16696 - xinetd doesn't execv() correctly
Summary: xinetd doesn't execv() correctly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xinetd (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-21 21:24 UTC by compwiz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-21 21:33:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description compwiz 2000-08-21 21:24:13 UTC
Using the latest xinetd RPM, when trying to use a service that uses the
'nobody' user (e.g. finger), the service does not execute and gives you
this message:

xinetd[3571]: execv( /usr/sbin/in.fingerd ) failed: Permission denied
(errno = 13)

Comment 1 Trond Eivind Glomsrxd 2000-08-21 21:30:01 UTC
Huh? This doesn't happen on our systems (which admittedly are a bit fresher, but
I don't recall fixing anything like that...) Everybody can execute in.fingerd?

Comment 2 compwiz 2000-08-21 21:33:48 UTC
ok, whoops. reverting back to RedHat 7 beta xinetd RPM doesn't fix this.
However, on my other computer, running Pinstripe stock,  these 'nobody' services
work fine..  This must be because of some other Rawhide package, but how do I
track it down?

Comment 3 Trond Eivind Glomsrxd 2000-08-21 21:40:37 UTC
finger-server? is nobody able to execute it? Anyway, this definitely works on
the current tree so I'll close the bug. Thanks for the report, though.


Note You need to log in before you can comment on or make changes to this bug.