Bug 1669605 - rebase systemtap for rhel7.7
Summary: rebase systemtap for rhel7.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemtap
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Frank Ch. Eigler
QA Contact: Martin Cermak
Vladimír Slávik
URL:
Whiteboard:
: 1610698 (view as bug list)
Depends On:
Blocks: 1643040 1610710
TreeView+ depends on / blocked
 
Reported: 2019-01-25 18:50 UTC by Frank Ch. Eigler
Modified: 2019-08-06 13:01 UTC (History)
6 users (show)

Fixed In Version: systemtap-4.0-9.el7
Doc Type: Enhancement
Doc Text:
.SystemTap rebased to version 4.0 The SystemTap instrumentation tool has been upgraded to upstream version 4.0. Notable improvements include: * The extended Berkeley Packet Filter (eBPF) backend has been improved, especially for strings and functions. To use this backend, start *SystemTap* with the [option]`--runtime=bpf` option. * A new export network service for use with the Prometheus monitoring system has been added. * The system call probing implementation has been improved to use the kernel tracepoints if necessary.
Clone Of:
Environment:
Last Closed: 2019-08-06 13:01:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2172 None None None 2019-08-06 13:01:14 UTC

Description Frank Ch. Eigler 2019-01-25 18:50:12 UTC
We'd like to rebase systemtap to 4.0 or later for rhel7.7, to bring in bpf and networking improvements.

Comment 5 Frank Ch. Eigler 2019-06-20 18:12:32 UTC
*** Bug 1610698 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2019-08-06 13:01:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2172


Note You need to log in before you can comment on or make changes to this bug.