Bug 166965 - qt combobox only uses scrollbars if editable.
qt combobox only uses scrollbars if editable.
Status: CLOSED DUPLICATE of bug 157809
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
/fedor/usr/share/doc/qt-devel-3.3.4/e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-28 23:04 EDT by Murdoch Ravli
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 04:32:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Murdoch Ravli 2005-08-28 23:04:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041221

Description of problem:
This is all very strange as fedora core 3 with the same qt worked correcyly. But now a combobox with a lot of data obscures the whole screen if started as a none editable combobox. However if started with editable contents, the combobox works correctly. The example at /usr/share/doc/qt-devel-3.3.4/examples/listboxcombo/ illustrates this perfectly the left combobox looks just fine and the right side one is not correct. The only differnce between the two is that the left one is started as editable IE you can enter data into it I suspect this will have bad results with kde applications as well. 

Version-Release number of selected component (if applicable):
compile the qt listboxcombo example. The left combo box is correct, the right one is wrong.

How reproducible:
Always

Steps to Reproduce:
1.Compile usr/share/doc/qt-devel-3.3.4/examples/listboxcombo/listboxcombo
2. Run it.
3. Observe how the left comb box is correct and the right side one is wrong
  

Actual Results:  The left side combobox was correct and the right side one was wrong.

Expected Results:  Both combo boxes should look the same except for the left one being editable.

Additional info:
Comment 1 Ngo Than 2005-08-29 04:32:54 EDT

*** This bug has been marked as a duplicate of 157809 ***

Note You need to log in before you can comment on or make changes to this bug.