Bug 166975 - snapshot gets conflicting device number at reboot
Summary: snapshot gets conflicting device number at reboot
Status: CLOSED DUPLICATE of bug 164959
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-29 10:52 UTC by Olle Liljenzin
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 19:58:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olle Liljenzin 2005-08-29 10:52:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Snapshot volumes get device numbers at boot that may conflict with persistent numbers used by other volumes. This may cause the system to hang.

In case a volume with conflicting number is present in fstab, you will get a chance to sort thing out when the filesystem check complaines about missing super block. If not in fstab, you will have use for the rescue disk to get back.

Version-Release number of selected component (if applicable):
lvm2-2.01.08-1.0.RHEL4

How reproducible:
Always

Steps to Reproduce:
1.Make the current device number persistent for an existing volume
E.g. 'lvdisplay /dev/VGSYS/foo' outputs 'Block device 253:7'
Run the commands:
% umount /dev/VGSYS/foo
% lvchange -M y --major 253 --minor 7 /dev/VGSYS/foo

2. Create a snapshot
% lvcreate -s -L 32M -n foo_snap /dev/VGSYS/foo

3. Reboot
  

Actual Results:  The machine will hang during boot because of conflicting device numbers

Expected Results:  The snapshot should get an unused device number

Additional info:

Comment 1 Olle Liljenzin 2005-08-29 18:37:25 UTC
This bug would be less urgent if bug 166750 was fixed.


Comment 3 Olle Liljenzin 2005-08-30 16:50:34 UTC
Decreasing severity since bug 166750 was closed.

Still a bug though.

Comment 4 Alasdair Kergon 2005-08-30 18:29:37 UTC
See 166750 for how to avoid this.

I can't think of anything the tools could do differently that would help.

An option to drop the persistent device number if it was not available.  That
would be tricky to code and I doubt it's worth the effort.

Perhaps a warning message if you set a persistent minor number smaller than the
number of LVs on your system?


Comment 5 Alasdair Kergon 2005-09-21 19:58:59 UTC
Not going to anything about this directly, but the proposed enhancements to
snapshots should stop the system hanging if a snapshot can't be activated.

*** This bug has been marked as a duplicate of 164959 ***


Note You need to log in before you can comment on or make changes to this bug.