Bug 166985 - export of the DISPLAY variable in ssh sesssions has no effect
export of the DISPLAY variable in ssh sesssions has no effect
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 09:07 EDT by Joachim Backes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 09:23:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2005-08-29 09:07:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Suppose you are ssh-ing from an primary (FC4) host to some other FC4 machine. Before doing this, you make an "xhost + <this other machine>". In the remote ssh session, you set the DISPLAY var to "<your primary host>:0". But now, if you are starting an X application on the remote FC4 machine, this appl is not able to make graphical output to the primary machine: Error: Can't open display:.

Even when using "ssh -X" for openeing a session to the remote machine an changing there the DISPLAY variable to <primary host>:0, graphical output to the primary host fails.

But a pure "ssh -X" to the remote host allows grraphical output with no trouble.

Version-Release number of selected component (if applicable):
openssh-4.1p1-3.1

How reproducible:
Always

Steps to Reproduce:
1.xhost +<remote host>
2.ssh <remote host>
3.remote_host#: export DISPLAY=<primary host>:0
4.remote_host#: start some graphical app on <remote host>
5. Error: Can't open display: ...
  

Actual Results:  see above

Expected Results:  see above

Additional info:

--
Comment 1 Tomas Mraz 2005-08-29 09:23:10 EDT
The X server listens only on UNIX sockets, not on IP. Using raw X over network
is a security nightmare.

ssh -X works because it redirects X communication through its encrypted connection.
Comment 2 Joachim Backes 2005-08-29 09:50:46 EDT
It seems this is a new effect of the X server. In earlier FedoraCore or RedHat
versions, working in this manner was possible (X is a network protocol, and
security is _my_ problem in this connection), so I am not satified with your
answer.!

Note You need to log in before you can comment on or make changes to this bug.