Bug 166986 - Vsftpd option 'user_config_dir' creates "500 OOPS: reading non-root config file" on user ftp login
Vsftpd option 'user_config_dir' creates "500 OOPS: reading non-root config fi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vsftpd (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks: 203675
  Show dependency treegraph
 
Reported: 2005-08-29 09:37 EDT by Jaak Simm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.3-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 06:02:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A better patch (1023 bytes, patch)
2006-06-21 11:54 EDT, Patrick Monnerat
no flags Details | Diff

  None (edit)
Description Jaak Simm 2005-08-29 09:37:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
I specified option 'user_config_dir' (=/some/dir) in /etc/vsftpd/vsftpd.conf. After doing that, all users that did not have a personal config file under the directory 'user_config_dir' received the following error, when logging into the ftp server:
 331 Please specify the password.
 Password:
 500 OOPS: reading non-root config file
 Login failed.
 421 Service not available, remote server has closed connection

If a personal config file (even an empty one) was placed into the user_config_dir the user was able to log in. My 'user_config_dir' did only contain user config files nothing else, and all of them were owned by root.

The bug does not exist in FC3 (with vsftpd-2.0.1-5). There users that do not have a personal config file can log in without a problem (with the option 'user_config_dir' set).

Version-Release number of selected component (if applicable):
vsftpd-2.0.3-1

How reproducible:
Always

Steps to Reproduce:
1. Add 'user_config_dir' to /etc/vsftpd/vsftpd.conf
2. (create the specified directory 'user_config_dir' and restart vsftpd)
3. Login to the ftp server with an ordinary user.
 

Actual Results:  Received error:
 500 OOPS: reading non-root config file

Expected Results:  Successful login to the ftp server.

Additional info:
Comment 1 Radek Vokal 2005-08-31 06:02:20 EDT
True, that's a small bug in one of my patches :)  Fix is comming rightaway. 
Comment 2 Patrick Monnerat 2006-06-21 11:54:25 EDT
Created attachment 131291 [details]
A better patch

Patch "vsfptd-2.0.3-user_config.patch" in rawhide and FC5 version (2.0.4-1.2)
is bad: it does not work all the time because it checks undefined data after an
error occurs (file not found error).
This is a better patch, ignoring user configuration files that do not success
on stat(). It REPLACES the 2.0.3 patch (i.e.: the 2.0.3 patch must not be
applied before the new one).
I think this bug should then be reopened, and reclosed when the new patch is
applied to downloadable updated package!
Comment 3 Maros Barabas 2006-09-19 06:55:53 EDT
Could you test the last version (vsftpd-2.0.5 in rawhide) and send a result please?

Note You need to log in before you can comment on or make changes to this bug.