Bug 1669894 - Error in naming file fedora-live-xfce.ks
Summary: Error in naming file fedora-live-xfce.ks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spin-kickstarts
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Václav Pavlín
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-27 19:14 UTC by Fomalhaut
Modified: 2019-07-08 01:08 UTC (History)
6 users (show)

Fixed In Version: spin-kickstarts-0.30.2-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-08 01:08:55 UTC


Attachments (Terms of Use)

Description Fomalhaut 2019-01-27 19:14:13 UTC
In the files /usr/share/spin-kickstarts/l10n/fedora-livecd-xfce-*.ks is written
%include ../fedora-livecd-xfce.ks
But this file is called a little differently:
fedora-live-xfce.ks

Comment 1 Fomalhaut 2019-02-01 15:20:08 UTC
# rpm -qa | grep kickstarts
l10n-kickstarts-0.29.2-1.fc29.noarch
spin-kickstarts-0.29.2-1.fc29.noarch
custom-kickstarts-0.29.2-1.fc29.noarch
fedora-kickstarts-0.29.2-1.fc29.noarch

Comment 2 Kevin Fenzi 2019-02-24 00:28:50 UTC
I've created an upstream PR to fix this: 

https://pagure.io/fedora-kickstarts/pull-request/487

should make its way out at some point. Thanks for the bug report!

Comment 3 Fomalhaut 2019-06-23 20:38:53 UTC
I tried to create my image based on F30 and again I encountered the same problem: an erroneous file name in the "include":
------------------
# cat /usr/share/spin-kickstarts/l10n/fedora-livecd-xfce-ru_RU.ks | grep -i "include" | grep -v "^#"
%include ../fedora-livecd-xfce.ks

$ cat /usr/share/spin-kickstarts/fedora-livecd-xfce.ks | grep -i "include" | grep -v "^#"
cat: /usr/share/spin-kickstarts/fedora-livecd-xfce.ks: No such file or directory

# cat /usr/share/spin-kickstarts/fedora-live-xfce.ks | grep -i "include" | grep -v "^#"
%include fedora-live-base.ks
%include fedora-live-minimization.ks
%include fedora-xfce-common.ks
------------------

There is no file fedora-livecd-xfce.ks, but there is a file fedora-live-xfce.ks.
Also in the body of the file is written the old file name: * -liveCD- *, instead of the current * -live- *. This is in many ks files.
------------------
$ cat fedora-live-xfce.ks | grep fedora-live | grep "#"
# fedora-livecd-xfce.ks
------------------

Comment 4 Kevin Fenzi 2019-06-24 15:46:42 UTC
What versions of spin-kickstarts / i10n-kickstarts do you have installed?

Comment 5 Fomalhaut 2019-06-24 17:52:15 UTC
# rpm -qa | grep kickstarts
fedora-kickstarts-0.30.1-1.fc30.noarch
spin-kickstarts-0.30.1-1.fc30.noarch
custom-kickstarts-0.30.1-1.fc30.noarch
l10n-kickstarts-0.30.1-1.fc30.noarch

Comment 6 Kevin Fenzi 2019-06-24 20:33:34 UTC
This was never pushed to f30, only fixed in rawhide/f31. 

I've submitted a PR for f30... would you like me to do a new release there as well, or can you just use the f30 git branch?

Comment 7 Fomalhaut 2019-06-25 17:10:37 UTC
I fixed it myself: it's not difficult to fix a text file. :-)
But besides me, someone else might come across, so I would like you to make a package on f30.
Thanx. :-)

Comment 8 Fedora Update System 2019-06-29 17:43:45 UTC
FEDORA-2019-c0414d3604 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c0414d3604

Comment 9 Fedora Update System 2019-06-30 01:16:36 UTC
spin-kickstarts-0.30.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c0414d3604

Comment 10 Fomalhaut 2019-06-30 10:26:44 UTC
Thank. Now everything is fine with the name of the files.
But there remains a small note on the description of the file name in the files themselves:
------------------
$ cat /usr/share/spin-kickstarts/fedora-live-xfce.ks
# fedora-livecd-xfce.ks
#
# Description:
# - Fedora Live Spin with the light-weight XFCE Desktop Environment
[...]
------------------
File:
/usr/share/spin-kickstarts/fedora-live-xfce.ks
But in the file its description:
# fedora-livecd-xfce.ks

Comment 11 Kevin Fenzi 2019-06-30 20:18:55 UTC
Yeah, there's a bunch more cosmetic things like that... would you care to make a patch or a pull-request for them?

I can try and fix them up someday, but I've got a lot higher priority items pending right now.

Comment 12 Fedora Update System 2019-07-08 01:08:55 UTC
spin-kickstarts-0.30.2-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.