Bug 166996 - Assert fail in gtk_container_propagate_expose crashed evolution and gthumb
Assert fail in gtk_container_propagate_expose crashed evolution and gthumb
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 11:01 EDT by Dave Jenkins
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.6.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 22:22:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace of evolution exit crash, with debuginfo (12.70 KB, text/plain)
2005-08-29 11:32 EDT, Dave Jenkins
no flags Details

  None (edit)
Description Dave Jenkins 2005-08-29 11:01:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Both evolution and gthumb have crashed today in gtk2 code. Following the gthumb crash I installed gtk2-debuginfo and gthumb-debuginfo. The evolution crash occurred after this, so I have what I hope will be a useful stack trace.

The gthumb crash occurred on hitting the Back button to change folder. I submitted a report against evolution using bugbuddy, but this has not yet found its way into the bug db.

The evolution crash occured when closing the app using the window manager close button.

Version-Release number of selected component (if applicable):
gtk2-2.6.7-4

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
I'm afraid this seems to be a UI bug that isn't readily reproducible. HOwever this is what I did.
gthumb crash:
1. Navigated to a folder via parent folders, using folder pane.
2. Viewed images in folder at full-screen.
3. Hit Return to normal view.
4. Hit Folders
5. Hit Back.

evolution crash:
1. Used app to check & read mail.
2. Hit window manager close button.
  

Actual Results:  gthumb/evolution crashed, bringing up bug buddy.

Expected Results:  gthumb should have displayed parent folder.
evolution should have closed down cleanly.

Additional info:

Stack trace to follow as attachment.
Comment 1 Dave Jenkins 2005-08-29 11:32:17 EDT
Created attachment 118208 [details]
Stack trace of evolution exit crash, with debuginfo
Comment 2 Matthias Clasen 2005-09-20 12:30:48 EDT
Do you still see this crash with GTK+ 2.6.10 ?
Comment 3 Dave Jenkins 2005-09-20 14:37:15 EDT
I haven't seen the crash again since the two occurrences on one day reported
above. I updated to gtk2-2.6.10-1 shortly after this became available through
updates-released, approx 9th Sep. So I've had approx 10 crash-free days with
each of 2.6.7 and 2.6.10 since my initial report. ;-)
Comment 4 Matthias Clasen 2005-10-02 22:22:19 EDT
I'll assume this is fixed in 2.6.10. Please reopen if you have reason to believe
that its not.

Note You need to log in before you can comment on or make changes to this bug.