Bug 167003 - refactoring fails
refactoring fails
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnston
:
Depends On: 171464
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 11:29 EDT by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 15:12:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Tromey 2005-08-29 11:29:19 EDT
I'm using eclipse cdt from rawhide: eclipse-cdt-3.0.0_fc-1.
I can't get refactoring to work.
To reproduce, make a small managed make project.
Then try to rename something -- a function, a variable name,
a class name (in a C++ project).
Eclipse will say that the operation would cause no source changes,
even though it obviously would if it worked.
If I run Eclipse with the Sun JDK, CDT refactoring works.
Comment 1 Tom Tromey 2005-09-09 12:53:15 EDT
ISTR that there is some evidence that disabling gcj-compilation
of the relevant jars works around this problem.
And I wonder if it is possibly an instance of:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=23182
Comment 2 Andrew Overholt 2005-10-21 14:41:15 EDT
If Anthony's comments are true in
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=23182#c8, when a rebuild against the
latest gcj happens (I'll do it in rawhide now and the blocker bug will be closed
when it finishes), can you verify that the problem is fixed/still there?
Comment 3 Andrew Overholt 2005-10-21 17:02:37 EDT
Trying with the latest rawhide build does not allow refactoring to work.  I will
verify that removing the native code still allows it to work.
Comment 4 Ben Konrath 2006-10-04 15:11:41 EDT
This bug is filed against FC4 which is no longer supported. Please re-test with
FC5 or FC6 and reopen the bug if the problem still exists. Thanks.

Note You need to log in before you can comment on or make changes to this bug.