Bug 1670056 - RHI: Unable to register CFME appliance via 'insights-client'
Summary: RHI: Unable to register CFME appliance via 'insights-client'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Build
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: 5.10.6
Assignee: Satoe Imaishi
QA Contact: Satyajit Bulage
Red Hat CloudForms Documentation
URL:
Whiteboard: appliance:rhi
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-28 14:01 UTC by Satyajit Bulage
Modified: 2019-09-26 03:12 UTC (History)
11 users (show)

Fixed In Version: 5.10.6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-02 04:33:27 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3563671 Troubleshoot None insights-client --register failing due to pkg_resources.DistributionNotFound: cryptography>=2.1.4 2019-06-05 01:06:20 UTC
Red Hat Product Errata RHBA-2019:1644 None None None 2019-07-02 04:33:36 UTC

Description Satyajit Bulage 2019-01-28 14:01:17 UTC
Created attachment 1524237 [details]
Error message file.

Description of problem: After subscribing CFME appliance to RHN, unable to register it using insights-client.


Version-Release number of selected component (if applicable): 5.10.0.32.20190115185124_c957ada


How reproducible:100%


Steps to Reproduce:
1. Subscribe CFME appliance.
2. Install insights-client pkg
3. Run 'insights-client --register'

Actual results: Throws error[see attachment] and system couldn't register


Expected results: It should not throw any error and system should register without any error.


Additional info:

Comment 8 Satyajit Bulage 2019-06-12 16:03:38 UTC
Verified Version: 5.10.6.0.20190610201431_b655f24

Comment 10 errata-xmlrpc 2019-07-02 04:33:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1644


Note You need to log in before you can comment on or make changes to this bug.