Bug 1670143 - [abrt] git-cola: _check_arg_types(): genericpath.py:149:_check_arg_types:TypeError: join() argument must be str or bytes, not 'NoneType'
Summary: [abrt] git-cola: _check_arg_types(): genericpath.py:149:_check_arg_types:Type...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: git-cola
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nikos Roussos
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3c0a885e8ab76b26b0ec4b6d347...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-28 17:07 UTC by Laurent Meunier
Modified: 2019-07-16 02:01 UTC (History)
6 users (show)

Fixed In Version: git-cola-3.3-1.fc29 git-cola-3.4-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-02 02:13:39 UTC


Attachments (Terms of Use)
File: backtrace (970 bytes, text/plain)
2019-01-28 17:07 UTC, Laurent Meunier
no flags Details
File: cgroup (345 bytes, text/plain)
2019-01-28 17:07 UTC, Laurent Meunier
no flags Details
File: cpuinfo (1.33 KB, text/plain)
2019-01-28 17:07 UTC, Laurent Meunier
no flags Details
File: environ (4.40 KB, text/plain)
2019-01-28 17:07 UTC, Laurent Meunier
no flags Details
File: mountinfo (3.95 KB, text/plain)
2019-01-28 17:07 UTC, Laurent Meunier
no flags Details
File: namespaces (129 bytes, text/plain)
2019-01-28 17:07 UTC, Laurent Meunier
no flags Details
File: open_fds (2.10 KB, text/plain)
2019-01-28 17:07 UTC, Laurent Meunier
no flags Details

Description Laurent Meunier 2019-01-28 17:07:09 UTC
Description of problem:
1. open git-cola and select a Maven project with modified files (some in "Staged", some in "Modified")
2. open a terminal and go to the Maven project folder
3. run a Maven compilation (mvn clean package)
4. git-cola crashes

Version-Release number of selected component:
git-cola-2.10-6.fc29

Additional info:
reporter:       libreport-2.9.7
cmdline:        /usr/bin/python3 /usr/bin/git-cola --prompt
crash_function: _check_arg_types
exception_type: TypeError
executable:     /usr/bin/git-cola
interpreter:    python3-3.7.2-4.fc29.x86_64
kernel:         4.20.3-200.fc29.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
genericpath.py:149:_check_arg_types:TypeError: join() argument must be str or bytes, not 'NoneType'

Traceback (most recent call last):
  File "/usr/share/git-cola/lib/cola/fsmonitor.py", line 216, in run
    self._handle_events()
  File "/usr/share/git-cola/lib/cola/fsmonitor.py", line 320, in _handle_events
    self._check_event(wd, mask, name)
  File "/usr/share/git-cola/lib/cola/fsmonitor.py", line 305, in _check_event
    core.decode(name)))
  File "/usr/lib64/python3.7/posixpath.py", line 94, in join
    genericpath._check_arg_types('join', a, *p)
  File "/usr/lib64/python3.7/genericpath.py", line 149, in _check_arg_types
    (funcname, s.__class__.__name__)) from None
TypeError: join() argument must be str or bytes, not 'NoneType'

Local variables in innermost frame:
funcname: 'join'
args: ('/home/laurent/Devel/atolcd/src/atolcd/alfresco-gda/gda/module_alfresco/src/main/webscripts/com/atolcd/alfresco/gda', None)
hasstr: True
hasbytes: False
s: None

Potential duplicate: bug 1505661

Comment 1 Laurent Meunier 2019-01-28 17:07:12 UTC
Created attachment 1524323 [details]
File: backtrace

Comment 2 Laurent Meunier 2019-01-28 17:07:13 UTC
Created attachment 1524324 [details]
File: cgroup

Comment 3 Laurent Meunier 2019-01-28 17:07:15 UTC
Created attachment 1524325 [details]
File: cpuinfo

Comment 4 Laurent Meunier 2019-01-28 17:07:16 UTC
Created attachment 1524326 [details]
File: environ

Comment 5 Laurent Meunier 2019-01-28 17:07:18 UTC
Created attachment 1524327 [details]
File: mountinfo

Comment 6 Laurent Meunier 2019-01-28 17:07:19 UTC
Created attachment 1524328 [details]
File: namespaces

Comment 7 Laurent Meunier 2019-01-28 17:07:20 UTC
Created attachment 1524329 [details]
File: open_fds

Comment 8 David Aguilar 2019-01-29 11:30:27 UTC
This was fixed in an earlier release.  Please run the latest from master to verify.   This is a dup of https://bugzilla.redhat.com/show_bug.cgi?id=1438522

Comment 9 Laurent Meunier 2019-01-30 07:53:29 UTC
Upgraded git-cola to version 3.2 (with dnf upgrade git-cola).
I'm not able to reproduce the bug anymore.

Thanks,
Laurent

Comment 10 Fedora Update System 2019-02-04 09:42:41 UTC
git-cola-3.3-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6038fcd228

Comment 11 Fedora Update System 2019-02-04 09:42:53 UTC
git-cola-3.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-99c132ee23

Comment 12 Fedora Update System 2019-02-04 09:43:04 UTC
git-cola-3.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-fe18a0bc67

Comment 13 Fedora Update System 2019-02-05 01:41:46 UTC
git-cola-3.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-99c132ee23

Comment 14 Fedora Update System 2019-02-05 02:04:44 UTC
git-cola-3.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-fe18a0bc67

Comment 15 Fedora Update System 2019-02-05 04:05:31 UTC
git-cola-3.3-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6038fcd228

Comment 16 Fedora Update System 2019-04-02 02:13:39 UTC
git-cola-3.3-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2019-06-28 16:19:39 UTC
FEDORA-EPEL-2019-0901e336dc has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-0901e336dc

Comment 18 Fedora Update System 2019-06-28 18:38:20 UTC
git-cola-3.4-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-0901e336dc

Comment 19 Fedora Update System 2019-07-16 02:01:20 UTC
git-cola-3.4-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.