Bug 167015 - Yum takes inordinate amount of time to run
Yum takes inordinate amount of time to run
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 12:07 EDT by Christopher Brown
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-30 14:28:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Brown 2005-08-29 12:07:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
When Yum is run it takes roughly one minute per repository to set up. This is running yum-2.4.0-1 from rawhide 20050829.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1519_FC5

How reproducible:
Always

Steps to Reproduce:
1. Run command "sudo yum update" from shell.
2. Note length of time to get and process data.

Actual Results:  Yum runs but takes about four minutes in all to check for updates.

Expected Results:  Nice and fast grabbing of repodata and processing with expected result depending on whether packages exist that need updating.

Additional info:

[chris@kilimanjaro ~]$ date && sudo yum -y update && date
Mon Aug 29 17:04:55 BST 2005
Setting up Update Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
livna                     100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
extras-development        100% |=========================| 1.1 kB    00:00
freshrpms                 100% |=========================|  951 B    00:00
Reading repository metadata in from local files
No Packages marked for Update/Obsoletion
Mon Aug 29 17:07:14 BST 2005
Comment 1 Seth Vidal 2005-08-29 12:13:49 EDT
I'm betting you have a failing name server and/or ipv6 name resolution going on
when it shouldn't be.

try disabling ipv6 support as described here:
http://www.fedorafaq.org/fc2/#mozillaipv6

and see if it all speeds up.
Comment 2 Christopher Brown 2005-08-30 14:20:51 EDT
Disabling ipv6 doesnt help and even if it did, it would just be another bug.
Workarounds are called as such because they do not resolve the underlying problem.
Comment 3 Christopher Brown 2005-08-30 14:28:16 EDT
...however you are spot on with regards to the failing name server. Is this an
error on my part and yum should not have to cope with dns that do not
exist/respond.....?
Comment 4 Seth Vidal 2005-08-30 18:59:35 EDT
the disabling ipv6 question wasn't about a workaround - but it would be another
bug filed against python, not yum. That's why I asked.

If your network card were flaking out and you were getting a slow connection
would that be yum's responsibility to know that?

no.

it can't be.



Note You need to log in before you can comment on or make changes to this bug.