Bug 1670279 - Better show simplified info when change architectures
Summary: Better show simplified info when change architectures
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-29 06:52 UTC by XiuJuan Wang
Modified: 2019-06-04 10:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:25 UTC

Description XiuJuan Wang 2019-01-29 06:52:35 UTC
Description of problem:
Show 'cannot change architectures from []string{"x86_64"} to []string{"ppc64le"}'
when set architectures from x86_64 to ppc64le

Version-Release number of selected component (if applicable):
$  oc get  clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-29-025207   True        False         1h        Cluster version is 4.0.0-0.nightly-2019-01-29-025207


How reproducible:
always

Steps to Reproduce:
1.Change architectures from x86_64 to ppc64le in samples operator
2.Check configs.samples.operator.openshift.io
3.

Actual results:

    Message:               cannot change architectures from []string{"x86_64"} to []string{"ppc64le"}
    Status:                False
    Type:                  ConfigurationValid

Expected results:
Better show simplified info when change architectures

Additional info:

https://github.com/openshift/cluster-samples-operator/blob/master/pkg/stub/config.go#L68

Comment 1 Gabe Montero 2019-02-06 15:09:55 UTC
PR https://github.com/openshift/cluster-samples-operator/pull/92 is up

Comment 2 Gabe Montero 2019-02-08 02:58:05 UTC
OK PR finally merged

Comment 3 XiuJuan Wang 2019-02-12 09:48:47 UTC
The promotion is friendly:
 
message: cannot change architectures from x86_64 to ppc64le

$oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-02-12-005016   True        False         24m     Cluster version is 4.0.0-0.nightly-2019-02-12-005016

Comment 6 errata-xmlrpc 2019-06-04 10:42:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.