Bug 1670311 - Should display the namespaces of the packagemanifest
Summary: Should display the namespaces of the packagemanifest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: Cuiping HUO
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-29 08:38 UTC by Jian Zhang
Modified: 2019-06-04 10:42 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:25 UTC

Description Jian Zhang 2019-01-29 08:38:50 UTC
Description of problem:
No namespace info list from the "oc get packagemanifest --all-namespaces" command.

Version-Release number of selected component (if applicable):
The OLM source commit:
io.openshift.build.commit.id=1e295784b30a7d54eb2db82b99a9c6307133ebbf
[jzhang@dhcp-140-18 ocp-29]$ oc version
oc v4.0.0-0.139.0
kubernetes v1.11.0+c69f926354
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://jian-5-api.qe.devcluster.openshift.com:6443
kubernetes v1.11.0+8868a98a7b

How reproducible:
always

Steps to Reproduce:
1. Install the OCP 4.0 cluster.
2. run "oc get packagemanifest --all-namespaces"

Actual results:
[jzhang@dhcp-140-18 ocp-29]$ oc get packagemanifest --all-namespaces
NAMESPACE   NAME                    AGE
            automationbroker        2h
            cluster-logging         2h
            descheduler             2h
            etcd                    2h
            federationv2            2h
            jaeger                  2h
            metering                2h
            prometheus              2h
            svcat                   2h
            templateservicebroker   2h
            amq-streams             2h
            packageserver           2h
            couchbase-enterprise    2h
            dynatrace-monitoring    2h
            mongodb-enterprise      2h

Expected results:
Should display the namespace info.

Additional info:

Comment 6 Jian Zhang 2019-04-19 06:14:43 UTC
It works well, LGTM, verify it.

Cluster version is 4.1.0-0.nightly-2019-04-18-210657
OLM version info:
               io.openshift.build.commit.id=c718ec855bb26a111d66ba2ba193d30e54f7feb1

mac:OCP-21082 jianzhang$ oc get packagemanifest --all-namespaces
NAMESPACE                              NAME                             CATALOG               AGE
openshift-marketplace                  aqua                             Community Operators   168m
openshift-marketplace                  automationbroker                 Community Operators   168m
openshift-marketplace                  camel-k                          Community Operators   168m
openshift-marketplace                  cluster-logging                  Community Operators   168m
openshift-marketplace                  cockroachdb                      Community Operators   168m
openshift-marketplace                  descheduler                      Community Operators   168m
openshift-marketplace                  elasticsearch-operator           Community Operators   168m
openshift-marketplace                  etcd                             Community Operators   168m
openshift-marketplace                  federation                       Community Operators   168m
openshift-marketplace                  federatorai                      Community Operators   168m
openshift-marketplace                  hazelcast-enterprise             Community Operators   168m
openshift-marketplace                  jaeger                           Community Operators   168m
openshift-marketplace                  metering                         Community Operators   168m
openshift-marketplace                  microcks                         Community Operators   168m
openshift-marketplace                  myvirtualdirectory               Community Operators   168m
openshift-marketplace                  node-network-operator            Community Operators   168m
openshift-marketplace                  node-problem-detector            Community Operators   168m
openshift-marketplace                  oneagent                         Community Operators   168m
openshift-marketplace                  opsmx-spinnaker-operator         Community Operators   168m
openshift-marketplace                  percona                          Community Operators   168m
openshift-marketplace                  planetscale                      Community Operators   168m
openshift-marketplace                  postgresql                       Community Operators   168m
openshift-marketplace                  prometheus                       Community Operators   168m
openshift-marketplace                  spark-gcp                        Community Operators   168m
openshift-marketplace                  strimzi-kafka-operator           Community Operators   168m
openshift-marketplace                  templateservicebroker            Community Operators   168m
default                                couchbase-enterprise-certified   Certified Operators   35m
openshift-operators                    amq-streams                      Red Hat Operators     35m
openshift-operators                    etcd                             Community Operators   7m1s
openshift-marketplace                  couchbase-enterprise-certified   Certified Operators   168m
openshift-marketplace                  mongodb-enterprise               Certified Operators   168m
openshift-marketplace                  planetscale-certified            Certified Operators   168m
openshift-marketplace                  robin-operator                   Certified Operators   168m
openshift-marketplace                  storageos                        Certified Operators   168m
openshift-marketplace                  sysdig-certified                 Certified Operators   168m
openshift-marketplace                  amq-streams                      Red Hat Operators     168m
default                                etcd                             Community Operators   49m
default                                federation                       Community Operators   49m
openshift-operators                    mongodb-enterprise               Certified Operators   97s
openshift-operator-lifecycle-manager   packageserver                    OLM Operators         174m

Comment 8 errata-xmlrpc 2019-06-04 10:42:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.