This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 167036 - cdrecord/growisofs does not verify data after burning media
cdrecord/growisofs does not verify data after burning media
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 14:18 EDT by Philip Prindeville
Modified: 2015-06-26 03:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-16 05:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 324256 None None None Never

  None (edit)
Description Philip Prindeville 2005-08-29 14:18:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
When one downloads and burns to media the FC installer CD's or DVD's, it's sometimes the case that you don't realize the CD (or DVD) has been burned incorrectly until several failed attempts at which point you consult a FAQ, and try the step "linux mediacheck"...  Only to find out that the CD didn't burn correctly.

A more expeditious solution would be to allow the nautilus CD burner (and cdrecord and/or growisofs) allow a readback of the written data to verify that what made it onto the disk is actually what was intended.

Perhaps even make this the default (after all, at 8x or 24x, verifying a disk doesn't take long at all).


Version-Release number of selected component (if applicable):
dvd+rw-tools-5.21.4.10.8-2

How reproducible:
Always

Steps to Reproduce:
1. do "man cdrecord"
2. Look for an option on verifying the data
3.
  

Actual Results:  There currently is no option to verify the data.

Additional info:

On a tangent...  it would be nice if a "linux mediacheck" could be repeatable from a running system (and not just as a boot option).

That way one could verify installer disks on the system that they were just burned on...
Comment 1 Tom Lane 2005-11-19 13:20:17 EST
After some similar bad experiences, I found that you can verify a CD with

dd if=/dev/cdrom bs=512 | cmp - originalimage.iso

(larger BS may work, but this seems fast enough).  I agree though that this
functionality ought to be integrated into nautilus-cd-burner, and probably
should be on by default.
Comment 2 Alexander Larsson 2005-12-16 05:56:44 EST
Not a bad idea. I filed an upstream request at:
http://bugzilla.gnome.org/show_bug.cgi?id=324256

I won't be able to do this, but maybe the upstream maintainer is interested.
Comment 3 Richard Jasmin 2015-06-26 03:21:27 EDT
NICE WISH. cdrecord and dvd+rw-tools DONT do this by default for a reason.Maybe you can persuade Brasero or k3b team to do so.I personally dont see the point.If your burning that many BAD discs, check your media type.It just might be a crappy brand.OR maybe your laser is dying.They do that you know.

Note You need to log in before you can comment on or make changes to this bug.