Bug 1670396 - KSieve fails to start
Summary: KSieve fails to start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pim-sieve-editor
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F30FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-01-29 13:32 UTC by Lukas Ruzicka
Modified: 2019-04-26 22:33 UTC (History)
11 users (show)

Fixed In Version: pim-sieve-editor-18.12.2-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-26 22:33:26 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 406902 None None None 2019-04-25 21:13:33 UTC

Description Lukas Ruzicka 2019-01-29 13:32:30 UTC
Description of problem:

KSieve Editor fails to start on a newly installed KDE Fedora Spin rawhide.

KCrash: Application 'sieveeditor' crashing...
KCrash: Attempting to start /usr/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0

Version-Release number of selected component (if applicable):

sieveeditor 5.10.1

How reproducible:

Always

Steps to Reproduce:
1. Run KSieve editor from Menu -> Applications > Internet > KSieve editor

Expected results:

Application starts flawlessly.

Comment 1 Lukas Ruzicka 2019-01-29 13:34:13 UTC
Journactl shows:

Jan 29 14:33:30 localhost.localdomain kwin_x11[1311]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 5976, resource id: 44041915, major code: 18 (ChangeProperty), minor code: 0
Jan 29 14:33:30 localhost.localdomain kwin_x11[1311]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 5981, resource id: 44041916, major code: 18 (ChangeProperty), minor code: 0
Jan 29 14:33:32 localhost.localdomain drkonqi[3016]: org.kde.drkonqi: Unable to find an internal debugger that can work with the KCrash backend
Jan 29 14:33:32 localhost.localdomain plasmashell[1317]: QQuickItem::stackAfter: Cannot stack StatusNotifierItem_QMLTYPE_269(0x55e8c5a79ba0, parent=0x55e8c3ab9790, geometry=0,0 0x0) after StatusNotifierItem_QMLTYPE_269(0x55e8c66a6630), which must be a sibling
Jan 29 14:33:32 localhost.localdomain plasmashell[1317]: file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/NotificationDelegate.qml:113: ReferenceError: appIcon is not defined

Comment 2 Rex Dieter 2019-01-29 22:35:28 UTC
If you can install gdb, so drkonqi can provide a backtrace, that would help debugging.

Comment 3 Lukas Ruzicka 2019-02-01 14:14:17 UTC
Here is the backtrace :)


Application: KSieve Editor (sieveeditor), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb345378980 (LWP 2258))]

Thread 4 (Thread 0x7fb334c1e700 (LWP 2262)):
#0  0x00007fb3519a8284 in read () from /lib64/libc.so.6
#1  0x00007fb350428870 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fb3503e0bab in g_main_context_check () from /lib64/libglib-2.0.so.0
#3  0x00007fb3503e1060 in ?? () from /lib64/libglib-2.0.so.0
#4  0x00007fb3503e11e0 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#5  0x00007fb351f1b5ab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#6  0x00007fb351ec9e0b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#7  0x00007fb351d31e86 in QThread::exec() () from /lib64/libQt5Core.so.5
#8  0x00007fb351d3b2fb in ?? () from /lib64/libQt5Core.so.5
#9  0x00007fb350dc85a3 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fb3519b7633 in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fb335f6a700 (LWP 2261)):
#0  0x00007fb3519ac721 in poll () from /lib64/libc.so.6
#1  0x00007fb3503e10b6 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fb3503e11e0 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fb351f1b5ab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007fb351ec9e0b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007fb351d31e86 in QThread::exec() () from /lib64/libQt5Core.so.5
#6  0x00007fb350df9f89 in ?? () from /lib64/libQt5DBus.so.5
#7  0x00007fb351d3b2fb in ?? () from /lib64/libQt5Core.so.5
#8  0x00007fb350dc85a3 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fb3519b7633 in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fb338150700 (LWP 2260)):
#0  0x00007fb3519ac721 in poll () from /lib64/libc.so.6
#1  0x00007fb35037339f in ?? () from /lib64/libxcb.so.1
#2  0x00007fb35037501a in xcb_wait_for_event () from /lib64/libxcb.so.1
#3  0x00007fb338282bf9 in ?? () from /lib64/libQt5XcbQpa.so.5
#4  0x00007fb351d3b2fb in ?? () from /lib64/libQt5Core.so.5
#5  0x00007fb350dc85a3 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fb3519b7633 in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fb345378980 (LWP 2258)):
[KCrash Handler]
#6  0x00007fb3527b8139 in QAction::setEnabled(bool) () from /lib64/libQt5Widgets.so.5
#7  0x00007fb352df2267 in SieveEditorMainWindow::slotUpdateActions() () from /lib64/libsieveeditor.so.5
#8  0x00007fb352df2913 in SieveEditorMainWindow::slotSystemNetworkOnlineStateChanged(bool) () from /lib64/libsieveeditor.so.5
#9  0x00007fb352df6e45 in SieveEditorMainWindow::SieveEditorMainWindow(QWidget*) () from /lib64/libsieveeditor.so.5
#10 0x000055a8caf36879 in ?? ()
#11 0x00007fb3518deee3 in __libc_start_main () from /lib64/libc.so.6
#12 0x000055a8caf3690e in _start ()
[Inferior 1 (process 2258) detached]

Comment 4 Geoffrey Marr 2019-04-25 17:05:54 UTC
Tested with F30 Beta Fedora-KDE-Live-x86_64-30-1.1 and am still seeing this bug.

Comment 5 Fedora Blocker Bugs Application 2019-04-25 17:11:51 UTC
Proposed as a Blocker for 30-final by Fedora user coremodule using the blocker tracking app because:

 Proposing as a blocker as it seems to violate the following Final critieria:

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

Comment 6 Adam Williamson 2019-04-25 20:24:15 UTC
I'm giving myself an hour or two to see if I can fix this crash before we try and take the app out.

Comment 7 Ben Cotton 2019-04-25 21:00:50 UTC
Discussed in the Fedora 30 Go/No-Go meeting blocker review:
https://meetbot.fedoraproject.org/fedora-meeting-1/2019-04-25/f30-final-go_no_go-meeting.2019-04-25-17.01.log.html#l-582

Accepted as a blocker because it violates the following Final criteria:
"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

Comment 8 Fedora Update System 2019-04-25 21:03:32 UTC
pim-sieve-editor-18.12.2-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e5343ff7b6

Comment 9 Rex Dieter 2019-04-25 21:13:34 UTC
Reported upstream,
https://bugs.kde.org/show_bug.cgi?id=406902

Comment 10 Julen Landa Alustiza 2019-04-26 06:45:16 UTC
It works on rc2 live

Comment 11 Lukas Ruzicka 2019-04-26 07:58:17 UTC
I can confirm, that it works on RC2 Live. I will also try Netinst.

Comment 12 Lukas Ruzicka 2019-04-26 08:46:35 UTC
I am sorry, but when the KDE spin is installed from Netinst, the KSieve editor still does not start. I do not consider the problem to be fixed and thus the blocker stays.

Comment 13 Lukas Ruzicka 2019-04-26 08:55:57 UTC
Now, I see that repositories still have the old version, because mine is still 18.12.2-1. So the problem might be fixed then. I will try to upgrade later and see.

Comment 14 František Zatloukal 2019-04-26 10:41:48 UTC
pim-sieve-editor-18.12.2-2.fc30 fixes the issue.

Comment 15 Geoffrey Marr 2019-04-26 16:27:49 UTC
Tested pim-sieve-editor-18.12.2-2.fc30 with Fedora-KDE-Live-x86_64-30-1.2. Works as it should, no trouble found.

Comment 16 Fedora Update System 2019-04-26 22:33:26 UTC
pim-sieve-editor-18.12.2-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.