Bug 1670647 - CLO logs have validation failures after install through marketplace and creation of clusterlogging CRD
Summary: CLO logs have validation failures after install through marketplace and creat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Mike Fiedler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-30 02:16 UTC by Mike Fiedler
Modified: 2019-06-04 10:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:36 UTC

Description Mike Fiedler 2019-01-30 02:16:43 UTC
Description of problem:

After installing cluster-logging through the marketplace, creation of clusterlogging CRDs results in a validation error in the CLO logs:

time="2019-01-29T20:51:53Z" level=error msg="error syncing key (openshift-logging/storageclassname): Unable to create or update logstore: Failure creating Elasticsearch CR: Elasticsearch.logging.openshift.io \"elasticsearch\" is invalid: []: Invalid value: map[string]interface {}{\"metadata\":map[string]interface {}{\"name\":\"elasticsearch\", \"namespace\":\"openshift-logging\", \"creationTimestamp\":\"2019-01-29T20:51:53Z\", \"ownerReferences\":[]interface {}{map[string]interface {}{\"apiVersion\":\"logging.openshift.io/v1alpha1\", \"kind\":\"ClusterLogging\", \"name\":\"storageclassname\", \"uid\":\"9994e1d5-2407-11e9-a060-06d58bf97baa\", \"controller\":true}}, \"generation\":1, \"uid\":\"b53ef32e-2407-11e9-a060-06d58bf97baa\"}, \"spec\":map[string]interface {}{\"managementState\":\"Managed\", \"nodeSpec\":map[string]interface {}{\"image\":\"quay.io/openshift/origin-logging-elasticsearch5:latest\", \"resources\":map[string]interface {}{}}, \"nodes\":[]interface {}{map[string]interface {}{\"nodeSpec\":map[string]interface {}{\"resources\":map[string]interface {}{}}, \"roles\":[]interface {}{\"client\", \"data\", \"master\"}, \"storage\":map[string]interface {}{\"size\":\"20G\"}, \"nodeCount\":3}}, \"redundancyPolicy\":\"SingleRedundancy\"}, \"status\":map[string]interface {}{\"shardAllocationEnabled\":\"\", \"clusterHealth\":\"\", \"conditions\":interface {}(nil), \"nodes\":interface {}(nil), \"pods\":interface {}(nil)}, \"apiVersion\":\"logging.openshift.io/v1alpha1\", \"kind\":\"Elasticsearch\"}: validation failure list:\nspec.nodes.roles in body must be of type object: \"array\""


Version-Release number of selected component (if applicable): OCP is 4.0.0-0.nightly-2019-01-29-025207.   Logging is latest via marketplace as of Jan 29


How reproducible: Always


Steps to Reproduce:
1. Install the logging operators from the marketplace
2. Create a clusterlogging resource in openshift-logging (hack/cr.yaml will have the issue)
3. oc logs on the cluster-logging-operator pod

Actual results:

Error as above

Comment 2 Mike Fiedler 2019-02-04 15:36:01 UTC
This still happens with the version of cluster-logging on the OperatorHub.  What has to happen to get a new version out there?

Comment 4 Mike Fiedler 2019-02-11 16:19:39 UTC
Verfified on 4.0.0-0.nightly-2019-02-11-045151

Comment 7 errata-xmlrpc 2019-06-04 10:42:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.