Bug 1670698 - Click Cancel doesn't quit creation flow on Developer Catalog
Summary: Click Cancel doesn't quit creation flow on Developer Catalog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-30 08:09 UTC by Yadan Pei
Modified: 2019-06-04 10:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:36 UTC

Description Yadan Pei 2019-01-30 08:09:22 UTC
Description of problem:
Click Cancel doesn't quit the creation flow on Developer Catalog page

Version-Release number of selected component (if applicable):
io.openshift.build.commit.id=5070df1f11d481f36152c0218f209a085eed9d64
io.openshift.build.commit.url=https://github.com/openshift/console/commit/5070df1f11d481f36152c0218f209a085eed9d64

How reproducible:
Always

Steps to Reproduce:
1. Catalog -> Developer Catalog -> Source-to-Image -> .NET -> Create Application -> Cancel
3.

Actual results:
2. Click Cancel doesn't redirect user to Developer Catalog list page, it opens the Create modal again

Expected results:
2. Click Cancel should quit creation flow and redirect user to Developer Catalog list page

Additional info:

Comment 1 Robb Hamilton 2019-01-30 15:10:58 UTC
PR to resolve: https://github.com/openshift/console/pull/1153

Comment 2 Yadan Pei 2019-02-01 07:59:38 UTC
Latest OCP payload registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-01-31-184459 doesn't include fix, will check on new build

Comment 3 shahan 2019-02-11 05:42:09 UTC
click cancel button will return developer catalog page.
cluster payload:    4.0.0-0.nightly-2019-02-10-115019
web commit : a766235ee842ce3547c7e18c8fa92f194251d608
verified this bug

Comment 6 errata-xmlrpc 2019-06-04 10:42:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.