Bug 1670704 (CVE-2019-7147) - CVE-2019-7147 nasm: Buffer over-read in function crc64ib in crc64.c resulting in denial of service
Summary: CVE-2019-7147 nasm: Buffer over-read in function crc64ib in crc64.c resulting...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2019-7147
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1670705
Blocks: 1670706
TreeView+ depends on / blocked
 
Reported: 2019-01-30 08:26 UTC by Dhananjay Arunesh
Modified: 2019-09-29 15:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:46:46 UTC


Attachments (Terms of Use)

Description Dhananjay Arunesh 2019-01-30 08:26:19 UTC
A buffer over-read exists in the function crc64ib in crc64.c in nasmlib in Netwide Assembler (NASM) 2.14rc16. A crafted asm input can cause segmentation faults, leading to denial-of-service.

References:
https://bugzilla.nasm.us/show_bug.cgi?id=3392544

Comment 1 Dhananjay Arunesh 2019-01-30 08:26:32 UTC
Created nasm tracking bugs for this issue:

Affects: fedora-all [bug 1670705]

Comment 3 Stefan Cornelius 2019-03-29 14:30:48 UTC
Statement:

This issue did not affect the versions of nasm as shipped with Red Hat Enterprise Linux 5, 6, and 7.


Note You need to log in before you can comment on or make changes to this bug.