Bug 1670709 - should be correct value for redirectURIs of oauthclients
Summary: should be correct value for redirectURIs of oauthclients
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Erica von Buelow
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-30 08:36 UTC by shahan
Modified: 2019-06-04 10:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:36 UTC

Description shahan 2019-01-30 08:36:52 UTC
Description of problem:
should be correct value for redirectURIs of oauthclients

Version-Release number of selected component (if applicable):
Cluster version is 4.0.0-0.nightly-2019-01-25-205123

How reproducible:
always

Steps to Reproduce:
1. oc get oauthclient openshift-browser-client -o json | jq -r '.redirectURIs'
2. oc get oauthclient |grep openshift-browser-client
3.

Actual results:
1.[
  "https://jian-5-api.qe.devcluster.openshift.com:6443/oauth/token/display",
  "/oauth/token/display"
]
2.
openshift-browser-client       XrKofbrmqDspTiSj_KOyRBGPacs6v_ueFk1bwtI7vaI   FALSE           default         https://jian-5-api.qe.devcluster.openshift.com:6443/oauth/token/display,/oauth/token/display


Expected results:
should have no the '/oauth/token/display' path as redirectURI

Additional info:

Comment 2 shahan 2019-03-12 08:50:20 UTC
[hasha@fedora_pc ~]$ oc get oauthclient openshift-browser-client -o json | jq -r '.redirectURIs'
[
  "https://openshift-authentication-openshift-authentication.apps.qe-yapei312.qe.devcluster.openshift.com/oauth/token/display"
]
[hasha@fedora_pc ~]$ oc get oauthclient |grep openshift-browser-client
openshift-browser-client       9IgDcNMzBm5SZMN1xpKTqsiaVbmcyXRUETCUQG_VUkg   FALSE           default         https://openshift-authentication-openshift-authentication.apps.qe-yapei312.qe.devcluster.openshift.com/oauth/token/display

clusterversion: 4.0.0-0.nightly-2019-03-06-074438

Comment 5 errata-xmlrpc 2019-06-04 10:42:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.