Bug 167079 - xen domain can't read drives,Cannot open root device
Summary: xen domain can't read drives,Cannot open root device
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xen   
(Show other bugs)
Version: 4
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Rik van Riel
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-30 01:32 UTC by Ted Kaczmarek
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 03:56:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ted Kaczmarek 2005-08-30 01:32:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
VFS: Cannot open root device "/dev/sda1" or unknown-block(0,0)
and
VFS: Cannot open root device "/dev/hda1" or unknown-block(0,0)

Version-Release number of selected component (if applicable):
kernel-xenU-2.6.12-1.1447_FC4

How reproducible:
Always

Steps to Reproduce:
1.Install xen on tyan 2462, 2 scsi, 2 ide scsi and 2 ide cd's
2.Try to start vm
3.
  

Actual Results:  VFS: Cannot open root device

Expected Results:  The vm should have found one of the drives.

Additional info:

kernel-xenU-2.6.12-1.1447_FC4
kernel-xen0-2.6.12-1.1447_FC4
xen-2-20050823

I have had simillar issues in the past with anaconda on this box as well, I need to get a new drive soon anyway, when I get it I will try to test with only 1 scsi drive.

Comment 1 Ted Kaczmarek 2005-08-30 15:38:49 UTC
I rebuilt the xend package using the spec file and patch from the rpm and the
tar ball at xen-source it plays nicer now.
I had to make a few changes in the %files section of the spec file some chnages.

Any explanation for the non dev crowd for this?

Comment 2 Rik van Riel 2005-08-30 16:04:17 UTC
Upstream xen-unstable is very aptly named.  It looks like there's always
something broken, and always something else ;(

Any time I resync to a different upstream Xen snapshot I'm essentially playing
russian roulette ;)

Comment 3 Ted Kaczmarek 2005-08-30 16:35:15 UTC
I will hit the xen-devel list for now, their is way too many things going on for
one bug report in bugzilla. If I get a build that plays nice on my SMP FC4 will
update.

Comment 4 Ted Kaczmarek 2005-10-02 03:56:02 UTC
More recent xen changeset's are behaving much better.


Note You need to log in before you can comment on or make changes to this bug.