Bug 16708 - libposix.so is missing
Summary: libposix.so is missing
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-22 01:01 UTC by Gerald Kelly
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 15:08:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar archive containing Lotus Notes C API program source & makefile (20.00 KB, application/octet-stream)
2000-08-22 01:06 UTC, Gerald Kelly
no flags Details

Description Gerald Kelly 2000-08-22 01:01:48 UTC
Attempted to compile a sample program from  the Lotus Notes R5.0.3 C  API
toolkit . (sample program is called intro)  The build fails because
libposix.so cannot  be found to link with.  A find search of my hard drive
cannot locate this file. This same sample program builds properly under
RedHat 6.2 (intel), as libposix.so  exists in /usr/lib

Comment 1 Gerald Kelly 2000-08-22 01:06:10 UTC
Created attachment 2798 [details]
tar archive containing Lotus Notes C API  program source &  makefile

Comment 2 Jakub Jelinek 2000-08-22 16:16:47 UTC
Actually, there was just libposix.a, never libposix.so, and it has always been
a dumb library for broken programs (it did not contain anything), so you can
safely remove it from the Makefiles. glibc itself provides POSIX mandated
interfaces (and -lpthread, -lrt and other libraries as needed).


Note You need to log in before you can comment on or make changes to this bug.