Bug 167082 - Kernel boot argument "nofloppy" has no effect
Kernel boot argument "nofloppy" has no effect
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-30 00:06 EDT by Philip Prindeville
Modified: 2014-03-16 22:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 22:06:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (628 bytes, patch)
2005-08-31 01:10 EDT, Philip Prindeville
no flags Details | Diff

  None (edit)
Description Philip Prindeville 2005-08-30 00:06:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
Booting from the FC3-i386.iso DVD image, on a system with no floppy controller, I still get the messages:

<6>inserting floppy driver for 2.6.9-1.667
<4>Using cfq io scheduler
<6>Floppy drive(s): fd0 is 1.44M
<4>floppy0: no floppy controllers found

even though I had booted with "linux nofloppy ..."


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. boot w/ linux nofloppy on an NX1750S mini-ITX board
2. look at vty4
3.
  

Additional info:
Comment 1 Dave Jones 2005-08-30 02:39:15 EDT
at a guess, the initrd scripts are loading it unconditionally.
Peter ?
Comment 2 Philip Prindeville 2005-08-31 01:10:19 EDT
Created attachment 118274 [details]
Proposed patch

Suggested fix, gleaned from looking at how "nomodules" works.
Comment 3 Peter Jones 2005-09-15 14:32:04 EDT
I'm not seeing what the bug is.  Have we documented "nofloppy" somewhere?

Regarding the patch, if you're booting from the CD, then changing rc.sysinit
won't help any, as the install CDs don't use the init system that an installed
system would.  Also, rc.sysinit isn't part of the initrd even on an installed
system.
Comment 4 Philip Prindeville 2005-09-15 15:00:11 EDT
Googling "linux nofloppy" showed that nofloppy is a known boot argument, though
you're right, it isn't clear if it's formally documented anywhere.

That notwithstanding, floppy-less computers are more and more common (such as
laptops and mini-ITX computers).

Being able to control the (currently) unconditional loading of the floppy
driver, which will then fail, is a win, since it cuts down an error message on a
condition that isn't actually an error.  That is, if you don't have a floppy
drive and you know this, then generating an error message when the floppy module
fails to load is hardly useful or informative.

But more to your point...  Where then does the floppy driver get loaded if not
in /etc/rc.d/rc.sysinit?  I'm talking about an installed system in this case.
Comment 5 Peter Jones 2005-09-16 11:32:08 EDT
On the installed system, yes, rc.sysinit.  But the log you pasted is from anaconda.

Is there actually an error message?  I don't really care about this message
showing up on tty4; it makes absolutely no difference.

I think you've just stumbled across some incorrect advice on the net.
Comment 6 Philip Prindeville 2005-09-19 15:35:11 EDT
Ok, so how do we fix it both on a running system and in Anaconda so that you can
avoid probing for the floppy drive?  On systems (especially prototype systems,
where you are trying to bring up new hardware and probing for devices might
cause instabilities) you might need a way to inhibit probing for a floppy drive.
Comment 7 Bill Nottingham 2005-09-19 22:06:44 EDT
install floppy /bin/true

in /etc/modprobe.conf will fix it for the installed system; there won't be any
separate handling of it for rc.sysinit.

Note You need to log in before you can comment on or make changes to this bug.