Bug 167093 - ACPI broken by 2.6.12-1.1447_FC4 on an ABIT TH7-II RAID m/b
ACPI broken by 2.6.12-1.1447_FC4 on an ABIT TH7-II RAID m/b
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-08-30 03:47 EDT by Ville Skyttä
Modified: 2015-01-04 17:21 EST (History)
8 users (show)

See Also:
Fixed In Version: 2.6.12-1.1456_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 02:12:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-08-30 03:47:38 EDT
ACPI appears to be broken in 2.6.12-1.1447_FC4 on a box with an ABIT TH7-II   
RAID motherboard.  No such problems with 2.6.12-1.1398_FC4.   
   
Some syslog lines produced by booting 2.6.12-1.1447_FC4:   
Aug 30 10:04:35 bobcat kernel:     ACPI-0287: *** Error: Region SystemIO(1)  
has no handler  
Aug 30 10:04:35 bobcat kernel:     ACPI-0127: *** Error: acpi_load_tables:  
Could not load namespace: AE_NOT_EXIST  
Aug 30 10:04:35 bobcat kernel:     ACPI-0136: *** Error: acpi_load_tables:  
Could not load tables: AE_NOT_EXIST  
Aug 30 10:04:35 bobcat kernel: ACPI: Unable to load the System Description  
Tables  
  
...and from 2.6.12-1.1398_FC4, no problems noticed there:  
Aug 30 10:28:29 bobcat kernel: ACPI: setting ELCR to 0200 (from 9c20) 
Aug 30 10:28:29 bobcat kernel: ACPI: Subsystem revision 20050309 
Aug 30 10:28:29 bobcat kernel: ACPI: Interpreter enabled 
Aug 30 10:28:29 bobcat kernel: ACPI: Using PIC for interrupt routing 
Aug 30 10:28:29 bobcat kernel: ACPI: PCI Root Bridge [PCI0] (0000:00) 
Aug 30 10:28:29 bobcat kernel: PCI: Probing PCI hardware (bus 00) 
Aug 30 10:28:29 bobcat kernel: PCI: Transparent bridge - 0000:00:1e.0 
Aug 30 10:28:29 bobcat kernel: ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 
10 *11 12 14 15) 
Aug 30 10:28:29 bobcat kernel: ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 
*10 11 12 14 15) 
Aug 30 10:28:29 bobcat kernel: ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 
10 11 12 14 *15) 
Aug 30 10:28:29 bobcat kernel: ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 
10 11 *12 14 15) 
Aug 30 10:28:29 bobcat kernel: ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 
10 11 12 14 15) *0, disabled. 
Aug 30 10:28:29 bobcat kernel: ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 
10 11 12 14 15) *0, disabled. 
Aug 30 10:28:29 bobcat kernel: ACPI: PCI Interrupt Link [LNK0] (IRQs 3 4 5 6 7 
10 11 12 14 15) *0, disabled. 
Aug 30 10:28:29 bobcat kernel: ACPI: PCI Interrupt Link [LNK1] (IRQs 3 4 *5 6 
7 10 11 12 14 15)
Comment 1 Greg 2005-08-31 03:36:06 EDT
Help!

After booting on this kernel disk now lists:

Failed to mount /mnt/disk2 :

mount: wrong fs type, bad option, bad superblock on /dev/hdb2,
       or too many mounted file systems

Cannot now use this disk.
Any ideas how to rescue it?
Comment 2 Dave Jones 2005-08-31 19:02:31 EDT
Greg, your bug is likely completely unrelated to this one. Please file another
one in order to not confuse the issue being reported here.
Comment 3 Mitch Smith 2005-09-01 23:27:39 EDT
1447_FC4 also has broken ACPI with IBM T21 laptop. Unit will not properly resume
after suspended. 1398_FC4 works fine. 
Comment 4 antonio montagnani 2005-09-02 05:41:38 EDT
Similar behaviour with ASUS P5P800 motherboard with updated BIOS
Furthermore the SMP kernel prevents from connecting to ADSL modem, standard
kernel  is o.k.
If I start SMP kernel with acpi=ht option I connect to the ADSL modem and to
Internet, but poweroff doesn't work (of course)
Comment 5 Mitch Smith 2005-09-02 17:45:02 EDT
1447_FC4 also has broken ACPI with IBM T21 laptop. Unit will not properly resume
after suspended. 1398_FC4 works fine. 
Comment 6 Roberto Bagnara 2005-09-03 06:50:12 EDT
The same thing happens for Asus M6862NEUP: ACPI is broken with
kernel-2.6.12-1.1398_FC4, but was working with kernel-2.6.12-1.1447_FC4.
Comment 7 Matthias Hensler 2005-09-06 10:17:36 EDT
I can confirm this with the ASUS M5678N. 2.6.12-1.1398_FC4 works,
2.6.12-1.1447_FC4 not. Same problem as above.
Comment 8 Matthias Hensler 2005-09-06 10:27:18 EDT
Testingkernel 2.6.12-1.1450_FC4 does _not_ resolve that issue for me.
Comment 9 Steffen Kluge 2005-09-07 01:51:33 EDT
ACPI problems too, with Intel Sonoma (PM 740) notebook (Fujitsu Lifebook N3510):

ACPI-0262: *** Error: Cannot release Mutex [MUT0], not acquired
ACPI-0509: *** Error: Method execution failed [\_SB_.BAT1._STA] (Node f7e25f80),
AE_AML_MUTEX_NOT_ACQUIRED
ACPI-0284: *** Error: Thread 9CF cannot release Mutex [MUT0] acquired by thread B99
ACPI-0509: *** Error: Method execution failed [\_SB_.BAT1._BST] (Node f7e25f40),
AE_AML_NOT_OWNER
ACPI-0145: *** Error: Invalid owner_id: 00
ACPI-0262: *** Error: Cannot release Mutex [MUT0], not acquired
ACPI-0509: *** Error: Method execution failed [\_SB_.PCI0.LPCB.EC0_._Q20] (Node
f7e21500), AE_AML_MUTEX_NOT_ACQUIRED
ACPI-0284: *** Error: Thread B99 cannot release Mutex [MUT0] acquired by thread C05
ACPI-0509: *** Error: Method execution failed [\_SB_.BAT1._BST] (Node f7e25f40),
AE_AML_NOT_OWNER
ACPI-0284: *** Error: Thread 9CF cannot release Mutex [MUT0] acquired by thread C05
ACPI-0509: *** Error: Method execution failed [\_SB_.BAT1._BST] (Node f7e25f40),
AE_AML_NOT_OWNER
ACPI-0145: *** Error: Invalid owner_id: 00
ACPI-0145: *** Error: Invalid owner_id: 00
ACPI-0262: *** Error: Cannot release Mutex [MUT0], not acquired
ACPI-0509: *** Error: Method execution failed [\_SB_.PCI0.LPCB.EC0_._Q20] (Node
f7e21500), AE_AML_MUTEX_NOT_ACQUIRED
ACPI-0145: *** Error: Invalid owner_id: 00
ACPI-0262: *** Error: Cannot release Mutex [MUT0], not acquired
ACPI-0509: *** Error: Method execution failed [\_SB_.PCI0.LPCB.EC0_._Q20] (Node
f7e21500), AE_AML_MUTEX_NOT_ACQUIRED
ACPI-0145: *** Error: Invalid owner_id: 00

etc, going on like this.
Comment 10 Ville Skyttä 2005-09-11 15:32:45 EDT
2.6.12-1.1450_FC4 from updates/testing seems to fix this for me. 
Comment 11 Kayvan Sylvan 2005-09-15 20:10:58 EDT
My kernel boots with 2.6.12-1.1398_FC4smp but does not boot (due to ACPI issue)
with 1447_FC4.

I'm running a dual-core (Pentium D) on an ASUS P5WD2 motherboard.

Both the SMP and single-processor versions of kernel-2.6.12-1.1447_FC4 start to
boot and then:

ACPI: Unable to load the System Description Tables

The boot then hangs at this point.
Comment 12 Kayvan Sylvan 2005-09-16 02:22:56 EDT
2.6.12-1.1450_FC4 fixes this problem for me as well.
Comment 13 Steve Parker 2005-09-27 19:41:34 EDT
The official 2.6.12-1.1456_FC4 fixes this on my ABIT TH7-II RAID.
Comment 14 Ville Skyttä 2005-09-28 02:12:48 EDT
That works for me too. 

Note You need to log in before you can comment on or make changes to this bug.