Bug 167101 - No am/pm information with locale es_ES
No am/pm information with locale es_ES
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-30 06:22 EDT by javier wilson
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.90-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 02:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description javier wilson 2005-08-30 06:22:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
I found this bug first using php: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167073

Joe Orton suggested I file this bug here. Then I checked /usr/lib/locale/es_ES/LC_TIME and noticed there was no AM/PM abbreviation.

Version-Release number of selected component (if applicable):
glibc-2.3.4-2.9

How reproducible:
Always

Steps to Reproduce:
1. using php run the following code:
setlocale(LC_TIME, "es_ES");
print "Time (es_ES): " . strftime("%I:%M %p") . "<br>\n";
setlocale(LC_TIME, "en_US");
print "Time (en_US): " . strftime("%I:%M %p") . "<br>\n";

Actual Results:  Time (es_ES): 05:36
Time (en_US): 05:36 PM

Expected Results:  Time (es_ES): 05:36 PM
Time (en_US): 05:36 PM

Additional info:
Comment 1 Jakub Jelinek 2005-08-30 07:35:28 EDT
And is there any, used commonly in Spain?
t_fmt_ampm is empty in es_ES (as well as in more than 50% of other locales),
which means that 12 hour format is not supported by the locale.
See http://www.opengroup.org/onlinepubs/009695399/basedefs/xbd_chap07.html
And when it is not supported, empty strings for AM and PM are IMHO just fine.
Comment 2 javier wilson 2005-08-30 11:07:02 EDT
Well, I have lived all my life in Peru, Mexico, Nicaragua, and have been to
Spain a few times, people use AM/PM all the time, in fact, most people don't
understand the 24hr format, i mean, they do understand it, it's just so rarely used.
Comment 3 Ulrich Drepper 2005-08-30 11:43:47 EDT
I very much doubt that anybody in Spain uses am/pm.  I have no idea about
Southamerica, but in Europe nobody really uses this format.  And for all
Southamerican countries you have to provide  prove.  Provide pointers to
official publications or newspapers which use the format.
Comment 4 javier wilson 2005-08-30 13:07:33 EDT
In Nicaragua: goverment: http://www.bcn.gob.ni/ http://www.ineter.gob.ni/
the two main newspapers: http://www.laprensa.com.ni/ http://www.elnuevodiario.com.ni

In Peru: goverment: http://www.congreso.gob.pe/ (all "citaciones" have am/pm)
http://www.pcm.gob.pe/ (all news items have am/pm) newspapers:
http://www.elcomercioperu.com.pe/

And you are right about Spain, people use AM/PM but officially it's the 24hr
format. But anyway, if people are familiar with the AM/PM thing shouldn't it 
be included in the locale file?

In Spanish AM/PM are the abbrevations for "antes meridiano" y "pasado meridiano"
so I believe it should be included in all the Spanish locale files. So that
people can use either format.
Comment 5 Ulrich Drepper 2006-08-01 22:10:20 EDT
I made changes to es_NI and es_PE.  But I won't change es_ES since it's
completely unnecessary.  The result will be in the next rawhide release.
Comment 6 Jakub Jelinek 2006-08-03 02:46:59 EDT
The changes are in glibc-common-2.4.90-17 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.