Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Created attachment 1525049[details]
reproducer
When run in batch mode, ip fails to execute an 'addr add' after a 'link add' without a 'link show' in between.
The following command succeeds:
ip -b - <<-'EOF'
netns add client
link add name veth-c type veth peer veth0 netns client
link show
addr add 192.168.0.1/24 dev veth-c
EOF
but removing the 'link show' will make it fail like this:
Cannot find device "veth-c"
Command failed -:3
I did a quick analysis, it seems that the 'link show' command updates an internal structure containing informations about interface name and indexes.
Not calling link show will leave this structure empty/incomplete, so iproute tries to get the interface with SIOCGIFINDEX, which fails.
ioctl(6, SIOCGIFINDEX, {ifr_name="veth-c"}) = -1 ENODEV (No such device)
iproute version:
root@rhel8:~# ip -V
ip utility, iproute2-ss180813
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHEA-2019:3602
Created attachment 1525049 [details] reproducer When run in batch mode, ip fails to execute an 'addr add' after a 'link add' without a 'link show' in between. The following command succeeds: ip -b - <<-'EOF' netns add client link add name veth-c type veth peer veth0 netns client link show addr add 192.168.0.1/24 dev veth-c EOF but removing the 'link show' will make it fail like this: Cannot find device "veth-c" Command failed -:3 I did a quick analysis, it seems that the 'link show' command updates an internal structure containing informations about interface name and indexes. Not calling link show will leave this structure empty/incomplete, so iproute tries to get the interface with SIOCGIFINDEX, which fails. ioctl(6, SIOCGIFINDEX, {ifr_name="veth-c"}) = -1 ENODEV (No such device) iproute version: root@rhel8:~# ip -V ip utility, iproute2-ss180813