Bug 167106 - modprobe asus_acpi exits with "no such device"
modprobe asus_acpi exits with "no such device"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-08-30 08:48 EDT by Mario Bruckschwaiger
Modified: 2015-01-04 17:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 05:49:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Bruckschwaiger 2005-08-30 08:48:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

Description of problem:
The kernel module asus_acpi can not be loaded with modprobe. The command exits with
FATAL: Error inserting asus_acpi (/lib/modules/2.6.12-1.1447_FC4/kernel/drivers/acpi/asus_acpi.ko): No such device

It worked perfectly with kernel-2.6.12-1.1398_FC4. The module was automatically loaded with this kernel and the special keys of my ASUS laptop worked.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1447_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel-2.6.12-1.1447_FC4
2. modprobe asus_acpi

  

Actual Results:  modprobe exits with

FATAL: Error inserting asus_acpi (/lib/modules/2.6.12-1.1447_FC4/kernel/drivers/acpi/asus_acpi.ko): No such device

and module is not loaded

Expected Results:  module should be loaded and special keys of my ASUS laptop should work.

Additional info:
Comment 1 Mario Bruckschwaiger 2005-08-30 09:02:06 EDT
Difference in dmesg:

does not work (kernel 2.6.12-1.1447):
...
ACPI: Subsystem revision 20050729
...
ACPI: AC Adapter [AC0] (on-line)
Asus Laptop ACPI Extras version 0.29
  L5D model detected, supported
ACPI: Battery Slot [BAT0] (battery absent)
ACPI: Power Button (FF) [PWRF]
ACPI: Sleep Button (CM) [SLPB]
ACPI: Lid Switch [LID]
ibm_acpi: ec object not found
ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
...

works (kernel 2.6.12-1.1398):
...
ACPI: Subsystem revision 20050309
...
ACPI: AC Adapter [AC0] (on-line)
Using generic hotkey driver
ACPI: Battery Slot [BAT0] (battery absent)
ACPI: Power Button (FF) [PWRF]
ACPI: Sleep Button (CM) [SLPB]
ACPI: Lid Switch [LID]
ACPI: Power Button (CM) [PWRB]
ibm_acpi: Using generic hotkey driver
toshiba_acpi: Using generic hotkey driver
ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
...
Comment 2 nazeman 2005-09-07 16:49:13 EDT
Same problem with ASUS A3G with FC3 
#uname -a
Linux asus 2.6.12-1.1377_FC3

#modprobe asus_acpi
FATAL: Error inserting asus_acpi
(/lib/modules/2.6.12-1.1377_FC3/kernel/drivers/acpi/asus_acpi.ko): No such device

with kernel 376 same problem.
# cat /proc/acpi/info
version:                 20050902
Comment 3 nazeman 2005-09-08 15:21:53 EDT
Additional info to post #2
# uname -a
Linux asus 2.6.12-1.1372_FC3
with this kernel is ok (x86 centrino)
Comment 4 Matthias Hensler 2005-09-23 06:23:27 EDT
asus_acpi worked for me on an M5678N notebook with 2.6.12-1.1398_FC4 (and older
ones).

Since 2.6.12-1.1447_FC4 this is broken for me. Neither 2.6.12-1.1450_FC4, nor
2.6.12-1.1456_FC4 has fixed this.

asus_acpi.ko cannot be loaded (no such device).

I am not sure if it is related, but since 2.6.12-1.1447_FC4 doing "cat
/proc/acpi/battery/BAT0/info" (or any other file in the BAT0-directory) takes a
long time, around ~30 seconds until I get (the correct output). This only
affects the battery-directory, others like cpu, fan, ac_adapter do not show this
problem.
Comment 5 Mario Curcija 2005-09-24 17:34:25 EDT
 A3800G family of notebooks (my box specifically A3843GLP) has same problem
starting with kernel 2.6.12-1.1447_FC4. 

Before that kernel version asus_acpi module loaded itself with message "A3G
model detected, unsupported". 
Here is an overview for different kernel versions: 

2.6.12-1.1398_FC4 
   asus_acpi module automatically loaded. Here is messge after modprobe
asus_acpi with previousely unloaded module.:
     A3G model detected, unsupported, trying default values, supply the
developers with your DSDT

   Another annoyance: KDE Session allways produced lots of :Asus ACPI: Error
reading LCD status 
  ...
  Sep 24 22:33:22 localhost kernel: Asus ACPI: Error reading LCD status
  Sep 24 22:33:53 localhost last message repeated 608 times
  Sep 24 22:34:54 localhost last message repeated 1216 times
  Sep 24 22:35:55 localhost last message repeated 1220 times
  Sep 24 22:35:58 localhost last message repeated 65 times
  ...
   
  GNOME Session on the other hand was free of those messages.

2.6.12-1.1447_FC4
   asus_acpi module does not load itself automatically. modprobe asus_acpi
returns with:
   FATAL: Error inserting asus_acpi
(/lib/modules/2.6.12-1.1447_FC4/kernel/drivers/acpi/asus_acpi.ko): No such device

   After some time notebook freezes (i was not able to finish this section
without freezing). And to mention of course dozen of following two messages
before that:

Sep 24 22:56:07 localhost kernel:     ACPI-0105: *** Error: Could not allocate
new owner_id (32 max),  AE_OWNER_ID_LIMIT
Sep 24 22:56:07 localhost kernel:     ACPI-0509: *** Error: Method execution
failed [\_SB_.PCI0.SBRG.EC0_.SMBR] (Node c18 dbe00), AE_OWNER_ID_LIMIT

   After booting with acpi=off problem disappeared.

2.6.12-1.1456_FC4
   asus_acpi module still does not load. modprobe asus_acpi returns with:
   FATAL: Error inserting asus_acpi
(/lib/modules/2.6.12-1.1447_FC4/kernel/drivers/acpi/asus_acpi.ko): No such
device. At least system does not freeze itselfs.
Comment 6 Joerg Knobloch 2005-09-25 05:38:30 EDT
I got the same errors with kernel versions newer than  2.6.12-1.1398_FC4 on my
Asus W1N series notebook.

asus_acpi.ko cannot be loaded (no such device).

If there's anything I can do (like testing patches and such), just contact me.
I'd be happy to help.
Comment 7 Dave Jones 2005-09-30 02:44:27 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 8 Mario Bruckschwaiger 2005-09-30 05:07:43 EDT
This kernel works for me.

Note You need to log in before you can comment on or make changes to this bug.