Bug 1671276 - The configuration for es pod cpu and memory doesn't take effect.
Summary: The configuration for es pod cpu and memory doesn't take effect.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-31 09:50 UTC by Qiaoling Tang
Modified: 2019-06-04 10:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:43:52 UTC

Description Qiaoling Tang 2019-01-31 09:50:02 UTC
Description of problem:
Deploy logging with configuration for pod cpu and memory, then check pod resource, the configuration for ES pod doesn't take effect.

$ oc get clusterlogging -o yaml |grep elasticsearch -A 10
      elasticsearch:
        nodeCount: 2
        redundancyPolicy: SingleRedundancy
        resources:
          limits:
            memory: 2Gi
          requests:
            cpu: "1"
            memory: 2Gi
        storage: {}
      type: elasticsearch
    managementState: Managed
$  oc get deployment --selector component=elasticsearch -o json |grep -A 9  resources
                                "resources": {
                                    "limits": {
                                        "cpu": "4",
                                        "memory": "4Gi"
                                    },
                                    "requests": {
                                        "cpu": "100m",
                                        "memory": "1Gi"
                                    }
                                },
--
                                "resources": {
                                    "limits": {
                                        "cpu": "4",
                                        "memory": "4Gi"
                                    },
                                    "requests": {
                                        "cpu": "100m",
                                        "memory": "1Gi"
                                    }
                                },
$ oc get pod --selector cluster-name=elasticsearch -o json |grep -A 9  resources
                        "resources": {
                            "limits": {
                                "cpu": "4",
                                "memory": "4Gi"
                            },
                            "requests": {
                                "cpu": "100m",
                                "memory": "1Gi"
                            }
                        },
--
                        "resources": {
                            "limits": {
                                "cpu": "4",
                                "memory": "4Gi"
                            },
                            "requests": {
                                "cpu": "100m",
                                "memory": "1Gi"
                            }
                        },
$ oc get elasticsearch -o yaml 
apiVersion: v1
items:
- apiVersion: logging.openshift.io/v1alpha1
  kind: Elasticsearch
  metadata:
    creationTimestamp: 2019-01-31T09:23:29Z
    generation: 1
    name: elasticsearch
    namespace: openshift-logging
    ownerReferences:
    - apiVersion: logging.openshift.io/v1alpha1
      controller: true
      kind: ClusterLogging
      name: customresourcefluentd
      uid: def5bd38-2539-11e9-b7bf-02cc5be6e37e
    resourceVersion: "157503"
    selfLink: /apis/logging.openshift.io/v1alpha1/namespaces/openshift-logging/elasticsearches/elasticsearch
    uid: df352b26-2539-11e9-bad9-0ae9db62b038
  spec:
    managementState: Managed
    nodeSpec:
      image: quay.io/openshift/origin-logging-elasticsearch5:latest
      resources: {}
    nodes:
    - nodeCount: 2
      resources: {}


Version-Release number of selected component (if applicable):
$ oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-30-174704   True        False         2h        Cluster version is 4.0.0-0.nightly-2019-01-30-174704

quay.io/openshift/origin-cluster-logging-operator@sha256:1a83682e275ee3e284a80272adf2ae7dd034ec87412bdca91887750637abab4b
quay.io/openshift/origin-elasticsearch-operator@sha256:154663cf5cce9b765166443b3c7f8b589b366ceb9feda27b4bfabbfa9c566020

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging using CR: https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/logging/clusterlogging/customresource-fluentd.yaml
2. check pod resources
3.

Actual results:


Expected results:


Additional info:

Comment 1 Qiaoling Tang 2019-01-31 09:51:46 UTC
correct:
$ oc get clusterlogging -o yaml |grep elasticsearch -A 10
      elasticsearch:
        nodeCount: 2
        redundancyPolicy: SingleRedundancy
        resources:
          limits:
            memory: 2Gi
          requests:
            cpu: 500m
            memory: 2Gi
        storage: {}
      type: elasticsearch

Comment 3 Anping Li 2019-02-12 10:01:29 UTC
The resource are enabled when using imageID: quay.io/openshift/origin-cluster-logging-operator@sha256:fd5ecd8523e55e3371f88f0a793715532deb38a553cd47dc413f488e3e7db4a2

Comment 6 errata-xmlrpc 2019-06-04 10:42:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.