Bug 167144 - import _apache
Summary: import _apache
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mod_python   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-30 21:58 UTC by Bryan W Clark
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 11:41:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan W Clark 2005-08-30 21:58:55 UTC
Errors out when trying to import one of the mod_python classes

[root@optimus-prime cgi-bin]# python
Python 2.4.1 (#1, May 16 2005, 15:19:29)
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import mod_python
>>> from mod_python import Session
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib/python2.4/site-packages/mod_python/Session.py", line 20, in ?
    import apache, Cookie
  File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 28, in ?
    import _apache
ImportError: No module named _apache

Comment 1 Bryan W Clark 2005-08-30 21:59:42 UTC
Oh, version stuff:

[root@optimus-prime ~]# rpm -qv mod_python
mod_python-3.1.4-2


Comment 2 Joe Orton 2005-08-31 09:15:19 UTC
What is this, Raw Hide, FC4, ...?

Comment 3 Bryan W Clark 2005-08-31 15:07:17 UTC
rawhide

Comment 4 Bryan W Clark 2005-09-09 15:05:58 UTC
This is all done solely from the command line and it was just suggested to me
that perhaps the module isn't intended to work outside of a python cgi script. 
In the cgi the module works fine.

Comment 5 Jim Gallacher 2005-09-18 20:42:49 UTC
mod_python is an apache module and is not intended for use outside of apache.


Note You need to log in before you can comment on or make changes to this bug.