Bug 167155 - Need to be able to re-prioritize connection choices
Need to be able to re-prioritize connection choices
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-30 23:53 EDT by Rodd Clarkson
Modified: 2008-05-21 21:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: NetworkManager-0.7.0-0.9.3.svn3669.fc9.i386
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 21:18:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OK Button greyed out (29.41 KB, image/png)
2008-05-01 07:56 EDT, Rodd Clarkson
no flags Details
output from bugbuddy (7.11 KB, text/plain)
2008-05-02 05:26 EDT, Rodd Clarkson
no flags Details

  None (edit)
Description Rodd Clarkson 2005-08-30 23:53:00 EDT
Description of problem:

My next door neighbor (whom I help with IT stuff from time to time) has a
wireless network, and I have one too.

Some time ago I did some work at his house and used NetworkManager for the first
time as he has WEP enabled and it was easier than trying to figure out how to do
it another way.  As a result I've continued to use NetworkManager as it's very good.

Unfortunately, while NetworkManager also happily connects to out wireless
router, everytime it senses his come on, it tries to connect to his instead of
staying connected to my router.

I assume that this has to do with the order in which the networks were connected
to using NM, and that his has a higer priority than mine.  However, I can't see
any way to reorder his prioritization so that my router has a higher precendent
than his.

This is really quite annoying having NM just try and switch wireless routers and
since I didn't remember his WEP passphrase the connection just dies.
Comment 1 Bug Zapper 2008-04-03 12:18:32 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 2 Rodd Clarkson 2008-04-29 22:56:13 EDT
This still seems to be an issue in rawhide.

There isn't any way I can see of saying whether I should try to automatically
connect to a hotspot, or dictating which order NM should try to connect.
Comment 3 Dan Williams 2008-05-01 06:52:17 EDT
To control automatic connections to a specific network, you can right-click on
the applet and choose "Edit Connections..." or run
/usr/bin/nm-connection-editor.  Find the connection you want in the tabs, then
click the "Edit..." button or double-click the connection.  There will be a
"Connect automatically" checkbox near the top.  Check/uncheck that however you
like, then hit OK.

NM will connect to the wireless network that you last successfully connected to,
if that network can be seen from scans.  You can delete networks you no longer
want from the connection editor which of course ensures that NM won't try to
connect to them again.  You can also lock a connection to a specific AP by
filling in the BSSID field in the connection editor; thus if you always want to
connect to a certain 'linksys' out of 5 other 'linksys' APs that your neighbors
are running, you can do that.

Basically, I think the existing methods should be able to provide what you need
to do, and we can likely tweak them if needed.  Can you give it a shot?  Thanks!
Comment 4 Rodd Clarkson 2008-05-01 07:56:54 EDT
Created attachment 304305 [details]
OK Button greyed out

Okay, all that looks good except that the OK button is greyed out trying to
edit a connection which makes it hard to apply the changes.
Comment 5 Dan Williams 2008-05-01 10:16:44 EDT
Please update to the latest NM for Fedora 9, that will likely fix this bug. 
You'll want svn3623 or later.
Comment 6 Rodd Clarkson 2008-05-01 20:01:09 EDT
Okay, the OK button is now clickable, but I did what you suggested, opened the
edit connections, selected Wireless, selected the AP, clicked edit, unclicked
Connect Automatically and then hit OK and something crashed.

I'll try to get a backtrace, but what debug packages do I need to install?
Comment 7 Rodd Clarkson 2008-05-02 05:26:59 EDT
Created attachment 304367 [details]
output from bugbuddy

I've installed NetworkManager-debuginfo and this is the backtrace.  Do I need
to also install debuginfo for nautilus, evolution or other packages, or is this
enough?
Comment 8 Dan Williams 2008-05-02 10:39:53 EDT
When you click on the "Wifi Security" tab in the connection editor, which option
is selected in the dropdown at the top?
Comment 9 Rodd Clarkson 2008-05-03 04:47:48 EDT
For this particular AP, it's "NONE"

I tried a couple of other AP I have listed and one which as WPA1/WPA2 works fine
when I click okay and another that has "NONE" also crashes when I click OK, so I
think you're on to something here.

Comment 10 Rodd Clarkson 2008-05-03 21:29:25 EDT
Interesting.  Two of the APs in my list still have the OK button greyed out.  

I've got seven all up, and the other five are fine (other than the "NONE" issue
above).
Comment 11 Dan Williams 2008-05-05 16:53:22 EDT
connection editor crash fixed in applet svn r712
Comment 12 Bug Zapper 2008-05-13 22:01:36 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Rodd Clarkson 2008-05-21 21:18:36 EDT
This all seems to be working now.

The OK button is active and clicking okay for items with Security set to NONE works.

Note You need to log in before you can comment on or make changes to this bug.