Bug 167159 - Incorrect rendering of indic languages in Firefox on RHEL4 'en' locale
Summary: Incorrect rendering of indic languages in Firefox on RHEL4 'en' locale
Status: CLOSED DUPLICATE of bug 139531
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-31 07:51 UTC by Runa Bhattacharjee
Modified: 2013-03-04 02:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 13:31:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of correct display of text (119.38 KB, image/png)
2005-08-31 07:53 UTC, Runa Bhattacharjee
no flags Details
Example of incorrect display of text (107.12 KB, image/png)
2005-08-31 07:54 UTC, Runa Bhattacharjee
no flags Details
Correct dislpay of text in gedit (113.36 KB, image/png)
2005-08-31 07:54 UTC, Runa Bhattacharjee
no flags Details
A text file containing bengali text for testing on the firefox interface. (2.34 KB, text/plain)
2005-09-03 08:50 UTC, Runa Bhattacharjee
no flags Details

Description Runa Bhattacharjee 2005-08-31 07:51:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; bn-IN; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
Text written in Indic languages (Bengali, Hindi, Gujarati, Punjabi, Tamil) incorrectly displayed in Firefox on RHEL4U1, en_US locale.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log-in to the en_US locale
2.Open Firefox web-browser
3.Open a page displaying any one of the above languages. (For bengali: http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/bn/x8664-multi-install-guide/)
4. Check that the encoding for the page is set to Unicode (View=>Character Encoding)

Actual Results:  Text in the web-page is displayed incorrectly ignoring conjuncts, displaying conjunct joiner signs and accurate positioning of dependent vowel signs.
<firefoxwrong.png>


Expected Results:  Text should be displayed correctly. Correct display of all the languages can be seen if logged onto any of the above 5 locales.
<firefoxright.png>

Additional info:


Gedit displays the text correctly even within the en_US locale. <gedit.png>

Comment 1 Runa Bhattacharjee 2005-08-31 07:53:27 UTC
Created attachment 118277 [details]
Example of correct display of text

Comment 2 Runa Bhattacharjee 2005-08-31 07:54:04 UTC
Created attachment 118278 [details]
Example of incorrect display of text

Comment 3 Runa Bhattacharjee 2005-08-31 07:54:33 UTC
Created attachment 118279 [details]
Correct dislpay of text in gedit

Comment 4 Leon Ho 2005-09-02 01:01:47 UTC
Runa, If you are in en_US locale, pango is disabled for firefox. You need to be
in Indic locales to have pango enabled for firefox.

Comment 5 Runa Bhattacharjee 2005-09-03 08:50:23 UTC
Created attachment 118418 [details]
A text file containing bengali text for testing on the firefox interface.

A text file containing bengali text for testing on the firefox interface.

Comment 6 Runa Bhattacharjee 2005-09-03 08:55:01 UTC
Hi Leon,
I tried using MOZ_ENABLE_PANGO=1 firefox from the command line in the en_US
locale on both RHEL4 AS4U1 and WS4U1. The bengali text rendered from the
web-site
(http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/bn/x8664-multi-install-guide/)
was correct. Without enabling PANGO the text is rendered incorrectly, hence if a
user tries to view indian language site on firefox from within a english locale
then he/she wouldnt be able to see it properly.
thanks
regards.

Comment 7 Warren Togami 2005-09-03 19:25:44 UTC
It is impossible to solve this bug without solving Bug #139531, which will
require fixing all pango rendering problems in Firefox.  This might be
considered a duplicate of Bug #139531 for this reason, but I will let someone
else make that decision.

Comment 8 Jens Petersen 2005-09-27 13:31:41 UTC
I agree with Warren's assessment.

*** This bug has been marked as a duplicate of 139531 ***


Note You need to log in before you can comment on or make changes to this bug.