Bug 167167 - megaraid2 kernel panic
megaraid2 kernel panic
Status: CLOSED DUPLICATE of bug 167166
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia32e Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-31 05:37 EDT by David Kostal
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 15:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kostal 2005-08-31 05:37:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 CentOS/1.0.4-1.4.1.centos3 Firefox/1.0.4

Description of problem:
After running bonnie++ for longer time in loop the kernel starts to report I/O errors on disk or panics.

Version-Release number of selected component (if applicable):
 2.4.21-35.EL, 2.4.21-32.0.1.EL and kernel-2.4.21-27.EL

How reproducible:
Sometimes

Steps to Reproduce:
1.run bonnie++ and wait for few hours

  

Actual Results:  I/O errors on disk or kernel panic

Expected Results:  system should run...

Additional info:

Host, OS info:
--------------
Dell PE 2850, 2xXeon, 12GB RAM, 1xPERC 4i/DC (1logical drive raid 10, scsi1, sdb), 1xPERC 4e/DC (1logical drive raid 10, scsi0, sda), 1xQLA2312 (no drives attached, scsi2)
BIOS A2

RedHat Enterprise Linux ES 3 U5 x86_64, latest updates

DELL PERC drivers:
megaraid2-v2.10.10.1-1dkms
dkms-2.0.5-1

Kernel from RHEL ES Beta:
kernel-2.4.21-35.EL

Filesystems: ext3, no sw raid, no lvm

reproducible: yes
After running 1 or 2 bonnie++ (one on sda, one on sdb) the kernel crashed after few hours of benchmarking in loop
I also tried kernels 2.4.21-35.EL, 2.4.21-32.0.1.EL and kernel-2.4.21-27.EL withe default megaraid2 from RH
Running bonnie++ on RH driver causes scsi I/O errors after some time of test.
Other symptoms:
It mmight happen that throuput for writing goes down to 100blocks/sec (according to iostat) even if there are many dirty buffers to be written, bonnie than takes more than night to finish. Reading from this disk (dd if=/dev/sda1) at the same time seems to improve write performance again.
Comment 1 Ernie Petrides 2005-08-31 15:23:30 EDT
Apparently, this was created by mistake (a double entry).

*** This bug has been marked as a duplicate of 167166 ***

Note You need to log in before you can comment on or make changes to this bug.