Bug 1671676 - [node-problem-detector-operator] The NPD operator is missing
Summary: [node-problem-detector-operator] The NPD operator is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Joel Smith
QA Contact: Weinan Liu
URL:
Whiteboard:
Depends On:
Blocks: 1664187
TreeView+ depends on / blocked
 
Reported: 2019-02-01 09:23 UTC by Weinan Liu
Modified: 2019-06-04 10:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:43:52 UTC

Description Weinan Liu 2019-02-01 09:23:37 UTC
Description of problem:
The NPD operator is missing
 
Version-Release number of selected component (if applicable):
$ oc get clusterversion 
NAME      VERSION     AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.1   True        False         6h        Cluster version is 4.0.0-0.1

OLM version: 0.8.1
The OLM code source version:
"io.openshift.source-repo-commit": "47482491fb29def1a3df05c3178b07de5761708f"

How reproducible:
always

Steps to Reproduce:
1. oc get packagemanifest -n openshift-marketplace

Actual results:
npd operator is missing
mac:aws-ocp jianzhang$ oc get packagemanifest
NAME                      AGE
amq-streams               5h
packageserver             5h
couchbase-enterprise      53m
descheduler               53m
mongodb-enterprise        53m
mongodb-enterprise-test   53m
couchbase-enterprise      5h
dynatrace-monitoring      5h
mongodb-enterprise        5h
automationbroker          5h
cluster-logging           5h
descheduler               5h
etcd                      5h
federationv2              5h
jaeger                    5h
metering                  5h
prometheus                5h
svcat                     5h
templateservicebroker     5

Expected results:
NPD operator is there

Additional info:

Comment 3 Weinan Liu 2019-02-14 11:26:55 UTC
Issue verified to be fixed

[nathan@localhost 0214]$ oc get packagemanifest -n openshift-marketplace|grep node-
node-problem-detector   4h

[nathan@localhost 0214]$ oc version
oc v4.0.0-0.101.0
kubernetes v1.11.0+0e214b3455
features: Basic-Auth GSSAPI Kerberos SPNEGO
^R
^C
[nathan@localhost 0214]$ oc version
oc v4.0.0-0.101.0
kubernetes v1.11.0+0e214b3455
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://anli-api.qe.devcluster.openshift.com:6443
kubernetes v1.12.4+dea588c
[nathan@localhost 0214]$ oc get clusterversions
NAME      VERSION                           AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.alpha-2019-02-13-200735   True        False         4h44m     Cluster version is 4.0.0-0.alpha-2019-02-13-200735

Comment 6 errata-xmlrpc 2019-06-04 10:42:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.