This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 167175 - init script wants to load unknown kernel module
init script wants to load unknown kernel module
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: diskdumputils (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nobuhiro Tachino
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-31 07:13 EDT by Terje Rosten
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-02 10:44:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Terje Rosten 2005-08-31 07:13:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; nb-NO; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The init script in the diskdumputils package, wants to load the kernel module scsi_dump. However this module is not present in the kernel package: 

$ rpm -ql kernel-smp-2.6.12-1.1398_FC4 | grep scsi_dump

However the diskdump module is included:

$ rpm -ql kernel-smp-2.6.12-1.1398_FC4 | grep diskdump 
/lib/modules/2.6.12-1.1398_FC4smp/kernel/drivers/block/diskdump.ko

I see from the changelog in the kernel package that netdump is broken:

* Thu Apr 07 2005 Dave Jones <davej@redhat.com>
- 2.6.12rc2
  - netdump/netconsole currently broken.

Is this still the case and does this mean that diskdump/scsi_dump is broken 
too?

(I used the diskdumputils as component, however maybe the kernel component is more correct).  






Version-Release number of selected component (if applicable):
diskdumputils-1.1.9-2
diskdumputils-1.1.9-2 kernel-smp-2.6.12-1.1398_FC4

How reproducible:
Always

Steps to Reproduce:
Set up diskdump and try to start the diskdump service:

$ service diskdump start
  

Actual Results:  diskdump is not activated.

Expected Results:  diskdump  is activated.

Additional info:
Comment 1 Nobuhiro Tachino 2005-08-31 08:55:39 EDT
This is not a bug. Fedora 4 kernel does not have scsi_dump module because
diskdump is not supported on Fedora 4.

Note You need to log in before you can comment on or make changes to this bug.