Bug 1671895 - [Docs] Document limitations on editing EL8-based VMs on EL7
Summary: [Docs] Document limitations on editing EL8-based VMs on EL7
Keywords:
Status: CLOSED DUPLICATE of bug 1739583
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.3.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ovirt-4.4.0
: ---
Assignee: Rolfe Dlugy-Hegwer
QA Contact: meital avital
URL:
Whiteboard:
Depends On: 1667478
Blocks: 1649222
TreeView+ depends on / blocked
 
Reported: 2019-02-02 03:20 UTC by SATHEESARAN
Modified: 2020-08-03 15:40 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1649222
Environment:
Last Closed: 2019-11-08 13:49:01 UTC
oVirt Team: Virt
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)
engine.log (977.44 KB, application/octet-stream)
2019-02-02 04:07 UTC, SATHEESARAN
no flags Details
screenshot showing taking snapshot of the VM (24.10 KB, image/png)
2019-02-02 04:15 UTC, SATHEESARAN
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3914591 0 None None None 2019-09-23 17:33:58 UTC

Internal Links: 1739583

Description SATHEESARAN 2019-02-02 03:20:12 UTC
Description of problem:
------------------------
RHEL 8 guest was successfully created with RHHI-V 1.5 environment. While trying to make the template of this RHEL 8 guest with 'Seal Template' option, error was observed with 'Failed to seal the template' from RHV Manager UI

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
RHHI 1.5
    - RHV 4.2.7
    - RHGS 3.4.1

How reproducible:
------------------
Always

Steps to Reproduce:
--------------------
1. Create a RHEL 8 guest
2. Poweroff the VM
3. Make a template of this guest with 'Seal Template'

Actual results:
---------------
Failed to seal the template

Expected results:
-----------------
Successful sealing of template

Additional info:
-----------------

RHV Manager UI Events:
	
Nov 13, 2018, 1:05:38 PM
Failed to seal Template RHEL8_Template (VM: appvm02).

--- Additional comment from SATHEESARAN on 2018-11-13 07:57:02 UTC ---

Snip from engine.log

<snip>

2018-11-13 13:05:35,079+05 INFO  [org.ovirt.engine.core.bll.VirtJobCallback] (EE-ManagedThreadFactory-engineScheduled-Thread-71) [78ed563b-9f16-46a7-9ba9-7fcf77864bbc] Command SealVmTem
plate id: 'b356d40a-806d-4816-a95f-3d87ee8837a3': job 'fae09b9a-eb4d-4249-b189-b7be2a8ed92c' execution was completed with VDSM job status 'failed'
2018-11-13 13:05:35,083+05 INFO  [org.ovirt.engine.core.bll.VirtJobCallback] (EE-ManagedThreadFactory-engineScheduled-Thread-71) [78ed563b-9f16-46a7-9ba9-7fcf77864bbc] Command SealVmTem
plate id: 'b356d40a-806d-4816-a95f-3d87ee8837a3': execution was completed, the command status is 'FAILED'
2018-11-13 13:05:36,085+05 ERROR [org.ovirt.engine.core.bll.SealVmTemplateCommand] (EE-ManagedThreadFactory-engineScheduled-Thread-56) [78ed563b-9f16-46a7-9ba9-7fcf77864bbc] Ending comm
and 'org.ovirt.engine.core.bll.SealVmTemplateCommand' with failure.
2018-11-13 13:05:37,112+05 INFO  [org.ovirt.engine.core.bll.SerialChildCommandsExecutionCallback] (EE-ManagedThreadFactory-engineScheduled-Thread-22) [78ed563b-9f16-46a7-9ba9-7fcf77864b
bc] Command 'AddVmTemplate' id: '8c4c86c9-628d-4f58-abff-199f934b922a' child commands '[067114b0-ec4c-4202-8a5e-b1662b1e5c3e, b356d40a-806d-4816-a95f-3d87ee8837a3]' executions were comp
leted, status 'FAILED'
2018-11-13 13:05:38,174+05 ERROR [org.ovirt.engine.core.bll.AddVmTemplateCommand] (EE-ManagedThreadFactory-engineScheduled-Thread-29) [78ed563b-9f16-46a7-9ba9-7fcf77864bbc] Ending comma
nd 'org.ovirt.engine.core.bll.AddVmTemplateCommand' with failure.
2018-11-13 13:05:38,182+05 INFO  [org.ovirt.engine.core.vdsbroker.SetVmStatusVDSCommand] (EE-ManagedThreadFactory-engineScheduled-Thread-29) [78ed563b-9f16-46a7-9ba9-7fcf77864bbc] START
, SetVmStatusVDSCommand( SetVmStatusVDSCommandParameters:{vmId='80d9f34e-5615-4ec5-8aeb-4a82b6a70e4a', status='Down', exitStatus='Normal'}), log id: 657e9ea6
2018-11-13 13:05:38,184+05 INFO  [org.ovirt.engine.core.vdsbroker.SetVmStatusVDSCommand] (EE-ManagedThreadFactory-engineScheduled-Thread-29) [78ed563b-9f16-46a7-9ba9-7fcf77864bbc] FINIS
H, SetVmStatusVDSCommand, log id: 657e9ea6
2018-11-13 13:05:38,193+05 INFO  [org.ovirt.engine.core.bll.AddVmTemplateCommand] (EE-ManagedThreadFactory-engineScheduled-Thread-29) [78ed563b-9f16-46a7-9ba9-7fcf77864bbc] Lock freed t
o object 'EngineLock:{exclusiveLocks='[654ca84c-62a6-4715-830e-bb7a18667ebb=DISK, RHEL8_Template=TEMPLATE_NAME, 7903571a-5093-4019-9fa5-a3322f76fd9c=TEMPLATE]', sharedLocks='[80d9f34e-5
615-4ec5-8aeb-4a82b6a70e4a=VM]'}'
2018-11-13 13:05:38,210+05 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (EE-ManagedThreadFactory-engineScheduled-Thread-29) [78ed563b-9f16-46a7-9ba9-7fcf
77864bbc] EVENT_ID: USER_ADD_VM_TEMPLATE_SEAL_FAILURE(1,324), Failed to seal Template RHEL8_Template (VM: appvm02).

</snip>

--- Additional comment from Sahina Bose on 2018-11-19 05:00:13 UTC ---

Can you clone this bug to RHV?

Comment 2 SATHEESARAN 2019-02-02 03:25:31 UTC
Error in engine.log looks like:

<snip>
2019-02-01 21:40:32,587+05 INFO  [org.ovirt.engine.core.bll.VirtJobCallback] (EE-ManagedThreadFactory-engineScheduled-Thread-34) [23b7bb1f-20a8-4624-b99b-a2eb3ae96292] Command SealVmTemplate id: 'f7e30c4c-d947-4c94-b195-f15b51f4bf90': job '0d120dac-b384-4644-8398-d965c6c40d73' execution was completed with VDSM job status 'failed'
2019-02-01 21:40:32,591+05 INFO  [org.ovirt.engine.core.bll.VirtJobCallback] (EE-ManagedThreadFactory-engineScheduled-Thread-34) [23b7bb1f-20a8-4624-b99b-a2eb3ae96292] Command SealVmTemplate id: 'f7e30c4c-d947-4c94-b195-f15b51f4bf90': execution was completed, the command status is 'FAILED'
2019-02-01 21:40:33,592+05 ERROR [org.ovirt.engine.core.bll.SealVmTemplateCommand] (EE-ManagedThreadFactory-engineScheduled-Thread-28) [23b7bb1f-20a8-4624-b99b-a2eb3ae96292] Ending command 'org.ovirt.engine.core.bll.SealVmTemplateCommand' with failure.
2019-02-01 21:40:35,751+05 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (EE-ManagedThreadFactory-engineScheduled-Thread-59) [23b7bb1f-20a8-4624-b99b-a2eb3ae96292] EVENT_ID: USER_ADD_VM_TEMPLATE_SEAL_FAILURE(1,324), Failed to seal Template RHEL8_Template (VM: appvm01).

</snip>

Comment 3 SATHEESARAN 2019-02-02 04:07:01 UTC
Created attachment 1526173 [details]
engine.log

Comment 5 SATHEESARAN 2019-02-02 04:13:02 UTC
Also while trying for the disk snapshot, the flow reports that it couldn't find the agent running.

Comment 6 SATHEESARAN 2019-02-02 04:13:26 UTC
(In reply to SATHEESARAN from comment #5)
> Also while trying for the disk snapshot, the flow reports that it couldn't
> find the agent running.

I will attach the screenshot of this

Comment 7 SATHEESARAN 2019-02-02 04:15:24 UTC
Created attachment 1526174 [details]
screenshot showing taking snapshot of the VM

This screenshot is about the RHV Manager complaining about the missing agent on the RHEL 8 guests and shows warning that the snapshot may be inconsistent

Comment 9 Mark Shoger 2019-04-17 13:31:40 UTC
This is not just for RHEL 8 guests. My customer is running RHEL 7.5 guests and we're seeing this exact same issue.

We have a 3 node RHHI (RHV 4.2 based) deployment in a completely disconnected lab environment. We're seeing the same issue when we try to create a template from a running VM.

"Failed preparing template <name> for sealing (VM:<UNKNOWN>)"

When we create a template with the virtual machine off, it works fine. We've tried creating (with the machine on) with RAW vs. QCOW2, with and without the memory state and it always fails.

Note that this customer is not able to provide logs, SOS output or screen shots.

Comment 10 Ryan Barry 2019-04-17 14:09:24 UTC
Mark, this is expected behavior, which is documented in the administration guide.

See https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.2/html/virtual_machine_management_guide/Creating_a_template_from_an_existing_virtual_machine

Specifically, the note that the VM must be powered off or down

Comment 11 W. de Heiden 2019-06-13 15:53:51 UTC
Regarding oVirt 4.3.4.3-1.el7 - the bug still seems to be there, cannot create a sealed template.

Comment 12 Ryan Barry 2019-08-09 15:23:27 UTC
Platform was closed NOTABUG. The best we'll be able to do here is try to ensure that sysprepping happens on EL8 hosts in mixed clusters on CCL 4.3

Comment 14 Marina Kalinin 2019-08-09 15:34:11 UTC
Bugzilla does not let me add a KCS today, so here it is:
https://access.redhat.com/solutions/3914591

And docs bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1739583

Comment 15 Ryan Barry 2019-08-26 14:42:30 UTC
See also: https://bugzilla.redhat.com/show_bug.cgi?id=1667478

Comment 16 Daniel Gur 2019-08-28 13:15:08 UTC
sync2jira

Comment 17 Daniel Gur 2019-08-28 13:20:10 UTC
sync2jira

Comment 18 Marina Kalinin 2019-11-08 13:49:01 UTC
I believe this should be a dup of this doc bug on RHV: bz#1739583.
If you believe this should be somewhere in RHHI-V specific documentation, please reopen and suggest where exactly.

Otherwise, this will be addressed once we switch to RHEL8 based hypervisors.

*** This bug has been marked as a duplicate of bug 1739583 ***


Note You need to log in before you can comment on or make changes to this bug.