Bug 167209 - ./ifup-wireless causes system to kinda hang
./ifup-wireless causes system to kinda hang
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-31 11:38 EDT by W Agtail
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 14:34:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snip from /var/log/messages (6.97 KB, text/plain)
2005-08-31 11:38 EDT, W Agtail
no flags Details

  None (edit)
Description W Agtail 2005-08-31 11:38:09 EDT
Description of problem:
./ifup-wireless causes system to kinda hang and does not configure wlan0.

Version-Release number of selected component (if applicable):
> rpm -qa|grep system-config-network
system-config-network-tui-1.3.26-1
system-config-network-1.3.26-1

> uname -r -p
2.6.12-1.1398_FC4 x86_64


How reproducible:
Always.


Steps to Reproduce:
system-config-network
New, Wireless connection, rt2500 (wlan0),
Mode:                                   Ad-Hoc
Network name (SSID):    Specified:      mine
Channel:                                1
Transmit rate:                          Auto
Key: (Use 0x for hex):                  12345qwertyui

Statically set IP address:
Address:                                172.19.19.20
Subnet mask:                            255.255.255.0
Default gateway address:
NB: I'm using peer-to-peer, so I leave gateway blank.

Apply, select wlan0 from main GUI (Network Configuration),
click 'Activate' button, answer 'Yes' to save changes, Click OK,

  
Actual results:
At this point, a windows titled 'system-config-network:' pops up with:
Activating network device wlan0, please wait...
./ifup-wireless: line 50: 10740 Segmentation fault
iwconfig $DEVICE channel $CHANNEL

and this message is broadcast to all open shell sessions;
Message from syslog@localhost at Wed Aug 21 16:07:24 2005 ...
localhost kernel: invalid operand: 0000 [1]


Expected results:
A working wlan0


Additional info:
'ifconfig -a' just hangs
unable to start any new desktop Apps
system appears to be alive :)


Manually setting wlan0 works just fine, but obviously doen't save to any
config files and bypasses ./ifup-wireless:
ifconfig wlan0 inet 172.19.19.20 broadcast 172.19.19.255 \
netmask 255.255.255.0 up

iwconfig wlan0 essid mine mode Ad-Hoc channel 1 rate auto key s:12345qwertyui

Also see attached /var/log/messages.

Any ideas?
Many thanks, W Agtail
Comment 1 W Agtail 2005-08-31 11:38:09 EDT
Created attachment 118305 [details]
snip from /var/log/messages
Comment 2 Harald Hoyer 2005-09-01 06:20:23 EDT
please run:
# sh -x ./ifup-wireless

then you'll see what segfaults
Comment 3 W Agtail 2005-09-01 16:02:31 EDT
Hi, not quite sure if this is what you're after?

rootl> pwd
/etc/sysconfig/network-scripts

root> sh -x ./ifup-wireless
+ '[' -n '' ']'
+ '[' -n '' -o -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' -a '' '!=' Managed ']'
+ '[' -n '' -a '' '!=' Managed ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' -o -n '' -o -n '' -o -n '' -o -n '' ']'
+ iwconfig key off
Error : unrecognised wireless request "off"
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ iwconfig essid any
Error : unrecognised wireless request "any"

rootl>

Thanks gain
Comment 4 Harald Hoyer 2005-09-02 03:51:38 EDT
no, ok, this wasn't what I wanted :)
but you already answered the question I had:
./ifup-wireless: line 50: 10740 Segmentation fault
iwconfig $DEVICE channel $CHANNEL

and this message is broadcast to all open shell sessions;
Message from syslog@localhost at Wed Aug 21 16:07:24 2005 ...
localhost kernel: invalid operand: 0000 [1]

so it seems, that the rt2500 driver has a problem.

does a simple:
# iwconfig wlan0 channel 1
segfault?
Comment 5 W Agtail 2005-09-02 07:56:16 EDT
Hmm, no sign of a segfault:

rootl> iwconfig wlan0 channel 1
rootl> ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:0F:EA:84:3F:F5
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:233 Base address:0xc000

rootl> iwconfig wlan0
wlan0     RT2500 Wireless  ESSID:""
          Mode:Managed  Frequency=2.412 GHz  Bit Rate=1 Mb/s
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=0/100  Signal level=-120 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

thanks again for your time on this.
any ideas?
Comment 6 W Agtail 2005-09-02 08:20:38 EDT
P.S. My knowledge of what conditions cause a segfault is zero :(
Would you be able to provide brief comments on this?

I was kinda under the impression that my case of segfault was some how caused by
ifup-wireless (or somewhere within the network start up scripts) as I'm able to
configure wlan0 manually.

Thanks.
Comment 7 W Agtail 2005-09-02 09:21:47 EDT
ha, now I get it, thanks for the inspiration :)
'rmmod rt2500' caused the segfault - nothing at all to do with startup scripts.

Latest CVS version fixed this.

Sorry :(

Regards W. Agtail

Note You need to log in before you can comment on or make changes to this bug.