Bug 167220 - Kadischi build fails if dietlibc is installed
Kadischi build fails if dietlibc is installed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kadischi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chitlesh GOORAH
Darko Ilic
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-31 13:31 EDT by Albert Strasheim
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-07 18:22:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Strasheim 2005-08-31 13:31:26 EDT
Description of problem:

If dietlibc is installed, Kadischi's build defaults to using it.

AC_PATH_PROG(DIET, diet, no)
AM_CONDITIONAL(USE_DIET, [test "x$DIET" != xno])

This is pretty annoying. It might be preferable if the use of dietlibc was only
enabled by passing the --enable-dietlibc flag to configure.

Also, when building against dietlibc, Kadischi tries to link against a library
called pci_loader which I can't anywhere.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install dietlibc.
2. Try to build Kadischi.
3.
  
Actual results:

Build fails.

Expected results:

Build should succeed. Preferably, build should default to not using dietlibc.

Additional info:
Comment 1 Jasper O. Hartline 2005-09-20 06:46:06 EDT
To fix this small hurdle, which may or may not be suggested in the near future,
rename /usr/bin/diet to say /usr/bin/temp-diet.

Then run the ./configure.
Since the ./cinfigure script queries specific binaries for determination of a
package being installed, you can overcome this like above. It would be different
if the script checked the rpmdb for the package, and still failed.

When you finish building and installing kadischi, rename temp-diet back to diet.
It hasn't moved an inch.
Comment 2 Christian Iseli 2007-01-19 02:22:33 EST
This bug hasn't been updated in a long time and targets FE devel.
Could you please check that it still occurs with current FE devel and update
accordingly ?

Thanks.
Comment 3 Jasper O. Hartline 2007-04-23 07:54:56 EDT
We don't use ditlibc anymore.
Comment 4 Chitlesh GOORAH 2007-07-07 18:22:46 EDT
Kadischi's development has stalled for a long time now.
There is no one to lead this project.

I'm therefore closing all open bugs related to kadischi as WONTFIX.

However I recommend you do try "revisor" to create your custom spins.
On Fedora 7, you can install revisor with:

yum install revisor

as root.

Note You need to log in before you can comment on or make changes to this bug.