Bug 1672312 - KDE menus differ according to the installation method.
Summary: KDE menus differ according to the installation method.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD - KDE
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sebastian Vahl
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-04 14:15 UTC by Lukas Ruzicka
Modified: 2019-04-06 10:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-06 10:52:20 UTC


Attachments (Terms of Use)
Screenshot from Live installation (786.92 KB, image/png)
2019-02-04 14:17 UTC, Lukas Ruzicka
no flags Details
Screenshot from Netinst installation (496.33 KB, image/png)
2019-02-04 14:18 UTC, Lukas Ruzicka
no flags Details

Description Lukas Ruzicka 2019-02-04 14:15:10 UTC
Description of problem:

When I install KDE from Live CD, some menu items differ from those that exist when installing from Everything netinst with the Anaconda KDE Desktop packages selection.

On, Live CD in the menu subgroup Administration, there are three items, while in the Everything netinst installation, there are four item in same subgroup. 

See the screenshots.

Version-Release number of selected component (if applicable):

I spotted it on the 20190121 compose.

How reproducible:

Always

Steps to Reproduce:
1. Install KDE Desktop using the above methods and see.

Expected results:

Menus should be the same, unless there is a good reason why not.

Comment 1 Lukas Ruzicka 2019-02-04 14:17:30 UTC
Created attachment 1526797 [details]
Screenshot from Live installation

Comment 2 Lukas Ruzicka 2019-02-04 14:18:12 UTC
Created attachment 1526798 [details]
Screenshot from Netinst installation

Comment 3 Lukas Ruzicka 2019-02-04 14:39:54 UTC
I realized that the original report was just a top of the iceberg, some applications are missing from the Netinst installation (such as games) but they are present in Live CD. We in our team believe that this should not be the case and that both installations should provide the same results.

Comment 4 edpil02 2019-02-10 16:22:39 UTC
(In reply to Lukas Ruzicka from comment #3)
> I realized that the original report was just a top of the iceberg, some
> applications are missing from the Netinst installation (such as games) but
> they are present in Live CD. We in our team believe that this should not be
> the case and that both installations should provide the same results.



i think that netinstall is a minimal base for a custom install, you have to complete with your own packages after reboot.

For plasma install,i use netinstall minimal (600 packages) then after chroot in the installer ,keep on install all the packages i need one by one or from a list and then reboot with a optimized os.
Sorry for my english.

Comment 5 Lukas Ruzicka 2019-02-18 12:37:55 UTC
Well, maybe, but I believe that Netinstall is a way to install Fedora using the Internet connection (in comparison to a LiveCD), so you can save some network capacity by downloading packages ones and not twice. Using netinstall gives you the latest packages, so it is not needed to update your system after fresh installation, which normally is the case when you use a prebuilt CD or DVD.

If, in Netinstall anaconda, I select to install KDE workstation, I expect that KDE workstation will be installed, as if I would use the KDE LiveCD. The installed applications differ from the LiveCD installation, but I do not see any purpose why it should differ.

Comment 6 edpil02 2019-02-18 18:59:15 UTC
Remember that fedora official workstation is gnome based.
Kde seems to be a spin, not officially support except by @kdesig ; that can explain differences between Livecd and netinstall.

Comment 7 Lukas Ruzicka 2019-02-26 11:14:36 UTC
(In reply to edpil02 from comment #6)
> Remember that fedora official workstation is gnome based.
> Kde seems to be a spin, not officially support except by @kdesig ; that can
> explain differences between Livecd and netinstall.

I am aware of that, but still ... I believe that this could be united, so the bug maybe should go to @kdesig for them to consider?

Comment 8 Kevin Kofler 2019-04-06 10:52:20 UTC
The "Add and Remove Users and Groups" tool is a GTK+ tool from the @administration comps group, which is deliberately blacklisted from the live image because there is comparable functionality in Plasma. Unfortunately, it is technically not possible to do this kind of blacklisting in Netinstall, where the KDE SIG controls only the @kde-desktop group, and groups cannot blacklist packages from other groups.


Note You need to log in before you can comment on or make changes to this bug.