Bug 167249 - "error enabling swap device" on install (w/no swap configured)
"error enabling swap device" on install (w/no swap configured)
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-31 17:30 EDT by Bill Waddington
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 13:22:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
parted & fdisk output (1.31 KB, text/plain)
2005-09-08 20:36 EDT, Bill Waddington
no flags Details

  None (edit)
Description Bill Waddington 2005-08-31 17:30:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

Description of problem:
Running stock FC4 install on Thinkpad R40. 4 Primary paritions: ntfs (winxp), fat32 (scratch), Solaris, Linux ext3.  The Linux partition has no prior installation, it was created with System Commander.  Solaris Nevada build 20 is installed in the Solaris paritition - ID 0xBF.

Disk druid sees the Solaris partition as swap, regardless of its ID.  I have tried BF, C, 7, and of course 82.

I tell the installer to format the existing 83 partition as root, ext3, and _do not_ select the "swap" partition for formatting.  I do not get a warning about no swap file.  When installation begins, it immediately stops with "error enabling swap device hda3".

It seems insane that the installer identifies the Solaris partition as swap regardless of its ID.  Also insane that it tries to format/enable (???) it when it is not selected for formatting.

I have built _many_ of these multiboot machines and never run into this before.   It is just possible that I have always installed RedHat/Fedore before Solaris, though.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.as above
2.
3.
  

Additional info:
Comment 1 Chris Lumens 2005-09-08 13:19:35 EDT
Could you please attach the output of:

parted /dev/hda p

Substitute your device in place of /dev/hda, of course.
Comment 2 Bill Waddington 2005-09-08 20:36:41 EDT
Created attachment 118618 [details]
parted & fdisk output
Comment 3 Bill Waddington 2005-09-08 20:42:03 EDT
Hmmm, my comments didn't go w/the attachment...

Hi Chris,

Thanks for following up on this.  As you can see, the Solaris ID isn't 82, but
parted (and anaconda/disk druid) still see it as swap.  IIRC, AF is the "hidden"
version of BF - the new Solaris ID.  System Commander is trying to hide other
partitions when booting Linux.  Disk druid also saw it as swap when the ID was
BF, and 07, and 0C, and ...

As I said earlier, IMNSO, it shouldn't have tried to enable it regardless of ID
since I had not selected it for formatting.

Thanks again,
Bill
Comment 4 Chris Lumens 2005-09-09 10:14:13 EDT
Looks to me like parted needs to be taught about the 0xaf partition type.  I'll
do some testing on this.
Comment 5 Bill Waddington 2005-09-09 10:20:59 EDT
Fair enough, but why does disk druid see the partition as swap when I change the
ID to 07?  For that matter, why does it try to use it when I don't enable swap
at all?
Comment 6 Christian Iseli 2007-01-22 05:34:48 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.

Note You need to log in before you can comment on or make changes to this bug.