Bug 1672528 - Since kernel 4.20.5-200.fc29 broken display brightness on AMD Radeon 6290.
Summary: Since kernel 4.20.5-200.fc29 broken display brightness on AMD Radeon 6290.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-05 09:30 UTC by Kirill Yushkov
Modified: 2019-08-21 00:41 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-21 00:41:52 UTC
Type: Bug


Attachments (Terms of Use)
dmesg from boot 4.20.5-200.fc29 (75.67 KB, text/plain)
2019-02-05 09:30 UTC, Kirill Yushkov
no flags Details

Description Kirill Yushkov 2019-02-05 09:30:32 UTC
Created attachment 1527061 [details]
dmesg from boot 4.20.5-200.fc29

1. Please describe the problem:
Since kernel 4.20.5-200.fc29 broken display brightness.

2. What is the Version-Release number of the kernel:
Linux localhost.localdomain 4.20.5-200.fc29.x86_64 #1 SMP Mon Jan 28 19:29:17 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
Yes, with 4.20.4-200.fc29.x86_64 and before.

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Always.
Boot kernel 4.20.5-200.fc29.x86_64

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
I can't install Rawhide kernel.
:(

[root@localhost kirya]# dnf update --enablerepo=rawhide kernel
Last metadata expiration check: 0:07:17 ago on Tue 05 Feb 2019 11:31:28 AM MSK.
Dependencies resolved.
================================================================================
 Package                 Arch      Version                    Repository   Size
================================================================================
Installing:
 kernel                  x86_64    5.0.0-0.rc4.git3.1.fc30    rawhide      22 k
 kernel-core             x86_64    5.0.0-0.rc4.git3.1.fc30    rawhide      27 M
 kernel-modules          x86_64    5.0.0-0.rc4.git3.1.fc30    rawhide      29 M
Removing:
 kernel                  x86_64    4.19.15-300.fc29           @updates      0  
 kernel-core             x86_64    4.19.15-300.fc29           @updates     60 M
 kernel-modules          x86_64    4.19.15-300.fc29           @updates     27 M
Removing dependent packages:
 kernel-modules-extra    x86_64    4.19.15-300.fc29           @updates    2.1 M

Transaction Summary
================================================================================
Install  3 Packages
Remove   4 Packages

Total size: 56 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] kernel-5.0.0-0.rc4.git3.1.fc30.x86_64.rpm: Already downloaded        
[SKIPPED] kernel-core-5.0.0-0.rc4.git3.1.fc30.x86_64.rpm: Already downloaded   
[SKIPPED] kernel-modules-5.0.0-0.rc4.git3.1.fc30.x86_64.rpm: Already downloaded
warning: /var/cache/dnf/rawhide-2d95c80a1fa0a67d/packages/kernel-5.0.0-0.rc4.git3.1.fc30.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID cfc659b9: NOKEY
Fedora - Rawhide - Developmental packages for t 1.6 kB/s | 1.6 kB     00:01    
Importing GPG key 0x429476B4:
 Userid     : "Fedora 29 (29) <fedora-29@fedoraproject.org>"
 Fingerprint: 5A03 B4DD 8254 ECA0 2FDA 1637 A20A A56B 4294 76B4
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-29-x86_64
Is this ok [y/N]: y
Key imported successfully
Import of key(s) didn't help, wrong key(s)?
Public key for kernel-5.0.0-0.rc4.git3.1.fc30.x86_64.rpm is not installed. Failing package is: kernel-5.0.0-0.rc4.git3.1.fc30.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-29-x86_64
Public key for kernel-core-5.0.0-0.rc4.git3.1.fc30.x86_64.rpm is not installed. Failing package is: kernel-core-5.0.0-0.rc4.git3.1.fc30.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-29-x86_64
Public key for kernel-modules-5.0.0-0.rc4.git3.1.fc30.x86_64.rpm is not installed. Failing package is: kernel-modules-5.0.0-0.rc4.git3.1.fc30.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-29-x86_64
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: GPG check FAILED
[root@localhost kirya]#


6. Are you running any modules that not shipped with directly Fedora's kernel?:
No.

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Kirill Yushkov 2019-02-07 07:40:02 UTC
The same situation is observed with the 4.20.6-200.fc29.x86_64 kernel.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 4.20.6-200.fc29.x86_64 #1 SMP Thu Jan 31 15:50:43 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 2 Kirill Yushkov 2019-02-15 09:14:56 UTC
The same situation is observed with the 4.20.7-200.fc29.x86_64 kernel.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 4.20.7-200.fc29.x86_64 #1 SMP Wed Feb 6 19:16:42 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 3 Kirill Yushkov 2019-02-19 08:38:35 UTC
The same situation is observed with the 4.20.8-200.fc29.x86_64 kernel.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 4.20.8-200.fc29.x86_64 #1 SMP Wed Feb 13 13:08:05 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 4 Kirill Yushkov 2019-02-20 09:56:13 UTC
The same situation is observed with the 4.20.10-200.fc29.x86_64 kernel.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 4.20.10-200.fc29.x86_64 #1 SMP Fri Feb 15 18:33:14 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 5 Kirill Yushkov 2019-02-20 10:27:00 UTC
I installed Rawhide kernel with --nogpgcheck

This problem is occur with the latest Rawhide kernel too.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 5.0.0-0.rc6.git1.1.fc30.x86_64 #1 SMP Wed Feb 13 15:51:45 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 6 Kirill Yushkov 2019-02-28 08:01:51 UTC
The same situation is observed with the 4.20.11-200.fc29.x86_64 kernel.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 4.20.11-200.fc29.x86_64 #1 SMP Wed Feb 20 15:56:08 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 7 Kirill Yushkov 2019-03-07 07:50:07 UTC
The same situation is observed with the 4.20.13-200.fc29.x86_64 kernel.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 4.20.13-200.fc29.x86_64 #1 SMP Wed Feb 27 19:42:55 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 8 Kirill Yushkov 2019-03-12 09:26:23 UTC
The same situation is observed with the 5.0.1-300.fc29.x86_64 kernel.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 5.0.1-300.fc29.x86_64 #1 SMP Tue Mar 12 05:53:27 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 9 Kirill Yushkov 2019-03-20 11:19:11 UTC
The same situation is observed with the 5.0.3-200.fc29.x86_64 kernel.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 5.0.3-200.fc29.x86_64 #1 SMP Tue Mar 19 15:07:58 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 10 Kirill Yushkov 2019-03-29 08:17:16 UTC
The same situation is observed with the 5.0.4-200.fc29.x86_64 kernel.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 5.0.4-200.fc29.x86_64 #1 SMP Mon Mar 25 02:27:33 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 11 Kirill Yushkov 2019-04-02 10:41:41 UTC
The same situation is observed with the 5.0.5-200.fc29.x86_64 kernel.
:(

kirya@localhost ~> uname -a
Linux localhost.localdomain 5.0.5-200.fc29.x86_64 #1 SMP Wed Mar 27 20:58:04 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Comment 12 Justin M. Forbes 2019-08-20 17:42:19 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 29 kernel bugs.

Fedora 29 has now been rebased to 5.2.9-100.fc29.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 30, and are still experiencing this issue, please change the version to Fedora 30.

If you experience different issues, please open a new bug report for those.

Comment 13 Kirill Yushkov 2019-08-21 00:41:52 UTC
I no longer have this hardware :(


Note You need to log in before you can comment on or make changes to this bug.