Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1672786

Summary: [Hackfest] After migration mapped bridges are looking for a controller, and leftover openflow rules are left in them
Product: Red Hat OpenStack Reporter: Miguel Angel Ajo <majopela>
Component: python-networking-ovnAssignee: Miguel Angel Ajo <majopela>
Status: CLOSED CURRENTRELEASE QA Contact: Eran Kuris <ekuris>
Severity: high Docs Contact:
Priority: high    
Version: 14.0 (Rocky)CC: apevec, jlibosva, lhh, lmarsh, lmartins, majopela, slinaber, twilson
Target Milestone: z4Keywords: TestOnly, Triaged, ZStream
Target Release: 14.0 (Rocky)Flags: majopela: needinfo-
majopela: needinfo-
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-networking-ovn-5.0.2-0.20190307204430.6a774a0.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-26 13:38:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1694572, 1700302, 1717144    
Bug Blocks:    

Description Miguel Angel Ajo 2019-02-05 22:09:08 UTC
Description of problem:

We see this on the ovs-vswitchd.logs of the hosts:

g Description
2019-02-05T16:48:24.078Z|00320|rconn|WARN|br-ex<->tcp:127.0.0.1:6633: connection failed (Connection refused)
2019-02-05T16:48:32.077Z|00321|rconn|WARN|br-ex<->tcp:127.0.0.1:6633: connection failed (Connection refused)
2019-02-05T16:48:40.078Z|00322|rconn|WARN|br-ex<->tcp:127.0.0.1:6633: connection failed (Connection refused)
2019-02-05T16:48:48.078Z|00323|rconn|WARN|br-ex<->tcp:127.0.0.1:6633: connection failed (Connection refused)
2019-02-05T16:48:56.077Z|00324|rconn|WARN|br-ex<->tcp:127.0.0.1:6633: connection failed (Connection refused)
2019-02-05T16:49:04.081Z|00325|rconn|WARN|br-ex<->tcp:127.0.0.1:6633: connection failed (Connection refused)
2019-02-05T16:49:12.078Z|00326|rconn|WARN|br-ex<->tcp:127.0.0.1:6633: connection failed (Connection refused)
2019-02-05T16:49:20.077Z|00327|rconn|WARN|br-ex<->tcp:127.0.0.1:6633: connection failed (Connection refused)

can be fixed by:

sudo ovs-vsctl set-fail-mode br-ex standalone
sudo ovs-vsctl del-controller br-ex

also all other bridge mapped bridges, this loop here looks like a good place to do it:
https://github.com/openstack/networking-ovn/blob/319ec6f54e98e6de8defa7a04a03fec0bc7021a7/migration/tripleo_environment/playbooks/roles/migration/templates/activate-ovn.sh.j2#L20

Comment 10 Jason Joyce 2019-06-07 18:02:35 UTC
According to our records, this should be resolved by python-networking-ovn-5.0.2-0.20190307204430.6a774a0.el7ost.  This build is available now.

Comment 11 Eran Kuris 2019-06-11 08:27:26 UTC
Can't verify before getting the fix of https://bugzilla.redhat.com/show_bug.cgi?id=1700302

Comment 16 Eran Kuris 2019-10-30 09:04:22 UTC
cant verify- depends on https://bugzilla.redhat.com/show_bug.cgi?id=1694572

Comment 19 Jakub Libosvar 2019-11-26 13:38:38 UTC
Closing as bug 1694572 won't make it to OSP14 before EOL.