Bug 1672802 - Satellite Registry does not accept HEAD requests
Summary: Satellite Registry does not accept HEAD requests
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Container Management - Content
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Mirek Długosz
URL:
Whiteboard:
: 1696824 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-05 23:33 UTC by Partha Aji
Modified: 2020-06-08 21:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
This has been fixed upstream, and will addressed in a future release.
Clone Of:
Environment:
Last Closed: 2020-06-08 21:05:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 26549 0 Normal Closed Unauthenticated pull not working for Head requests 2020-06-08 21:00:09 UTC

Description Partha Aji 2019-02-05 23:33:38 UTC
1) Create and Sync a docker repo (url = https://quay.io/  upstream name = openshift-release-dev/ocp-release)
2) Go to the life cycle environment details to allow  "unauthenticated pull" for library.
3) Try the following command

$ curl --head -L https://<fqdn>/v2/default_organization-custom-ocp/manifests/4.0.0-0


Expected:
200 Ok listing the manifest headers

Actual:
401 not authorized.

Comment 5 Brad Buckingham 2019-04-05 17:34:59 UTC
*** Bug 1696824 has been marked as a duplicate of this bug. ***

Comment 6 Partha Aji 2019-04-05 18:46:33 UTC
Connecting redmine issue https://projects.theforeman.org/issues/26549 from this bug

Comment 7 Bryan Kearney 2019-04-08 14:06:16 UTC
Upstream bug assigned to paji@redhat.com

Comment 8 Bryan Kearney 2019-04-08 14:06:18 UTC
Upstream bug assigned to paji@redhat.com

Comment 9 Bryan Kearney 2019-04-22 14:06:12 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/26549 has been resolved.

Comment 10 Brad Buckingham 2020-06-08 21:05:21 UTC
The fix for this was included in Satellite 6.6; therefore, closing this one as CURRENTRELEASE. 

If there are any concerns, please re-open with the appropriate details.


Note You need to log in before you can comment on or make changes to this bug.