Bug 1672904 - Build Config's are not editable on WebConsole
Summary: Build Config's are not editable on WebConsole
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.11.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-06 07:48 UTC by Rutvik
Modified: 2019-04-11 05:38 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When the ImageStream that is used in the BuildConfig is missing or user hasn't got permissions to use it, we need to create one in the scope of the ImageStreamTag component, so the BC editor won't error out. There was an issue that we have been initialising the tags by an object , instead of array. Consequence: Runtime error in the BC editor Fix: Initialise tags with and object Result: No runtime errors even though ImageStream in the BuildConfig is missing or user hasn't got permissions to use it.
Clone Of:
Environment:
Last Closed: 2019-04-11 05:38:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0636 None None None 2019-04-11 05:38:35 UTC

Description Rutvik 2019-02-06 07:48:56 UTC
Description of problem:

After upgrading OCP to 3.11, the customer is not able to edit the buildconfig from the console. It always stuck after clicking on the save button.

However, same build config can be edited and saved successfully from the cli with the same user. We have checked that the user logged on the console has admin rights for the project but can't save the build object.

We have tried this with a couple of openshift template and found the same issue for applications like cake-php, httpd, etc.

Attaching images for reference.

# rpm -qa | grep openshift
openshift-ansible-roles-3.11.51-2.git.0.51c90a3.el7.noarch
atomic-openshift-hyperkube-3.11.51-1.git.0.1560686.el7.x86_64
openshift-ansible-docs-3.11.51-2.git.0.51c90a3.el7.noarch
atomic-openshift-node-3.11.51-1.git.0.1560686.el7.x86_64
openshift-ansible-playbooks-3.11.51-2.git.0.51c90a3.el7.noarch
atomic-openshift-clients-3.11.51-1.git.0.1560686.el7.x86_64
openshift-ansible-3.11.51-2.git.0.51c90a3.el7.noarch
atomic-openshift-3.11.51-1.git.0.1560686.el7.x86_64
atomic-openshift-docker-excluder-3.11.51-1.git.0.1560686.el7.noarch
atomic-openshift-excluder-3.11.51-1.git.0.1560686.el7.noarch

Comment 3 Samuel Padgett 2019-02-06 13:47:02 UTC
Can you check the JavaScript console in your browser developer tools to see if there are any JavaScript errors? What edits are you making to the build config?

https://developer.mozilla.org/en-US/docs/Learn/Common_questions/What_are_browser_developer_tools#How_to_open_the_devtools_in_your_browser
https://developer.mozilla.org/en-US/docs/Learn/Common_questions/What_are_browser_developer_tools#The_JavaScript_console

Comment 9 Yadan Pei 2019-02-13 08:31:21 UTC
$ git log atomic-openshift-web-console-3.11.82-1 -1
commit 0ff1e2620bf355d36998510e1e2f4bbc2a80c4d9 (tag: atomic-openshift-web-console-3.11.82-1)
Author: AOS Automation Release Team <aos-team-art@redhat.com>
Date:   Thu Feb 7 20:10:08 2019 -0500

    bump origin-web-console 47a8bb4a

$  git log --pretty="%h %cd - %s" 47a8bb4a | grep '#3117'     // nothing returns, that means v3.11.82 doesn't include the fix

I used BC in comment 4, but still unable to reproduce the issue

here's a recording of steps I tried to reproduce: http://g.recordit.co/GgcPCaG07Z.gif

As you can see, Source Repo and Run Policy are successfully updated 

@Jakub, can you tell me how did you reproduce it?

Comment 11 Yadan Pei 2019-02-25 02:00:08 UTC
1. Create Node.js application from Catalog
2. Confirm ImageStream is successfully created
# oc describe is case-02299469 -n yapei11
Name:			case-02299469
Namespace:		yapei11
Created:		58 seconds ago
Labels:			app=case-02299469
Annotations:		openshift.io/generated-by=OpenShiftWebConsole
Docker Pull Spec:	docker-registry.default.svc:5000/yapei11/case-02299469
Image Lookup:		local=false
Unique Images:		1
Tags:			1

latest
  no spec tag

  * docker-registry.default.svc:5000/yapei11/case-02299469@sha256:3983e0400c04947bb0d81686479b25a8aa40b7291093a8181a845943dbbeddc1
      15 seconds ago
3. Goes to Builds -> Builds -> case-02299469 -> Actions -> Edit -> change source repo and add environment variables -> Save
the changes are saved successfully, recording here http://g.recordit.co/po51XBlWIQ.gif




1. Create BuildConfig from comment 2 directly
# oc describe bc -n yapei12
Name:		case-02299469
Namespace:	yapei12
Created:	26 seconds ago
Labels:		app=case-02299469
Annotations:	openshift.io/generated-by=OpenShiftWebConsole
Latest Version:	1

Strategy:	Source
URL:		https://github.com/openshift/nodejs-ex.git
Ref:		master
From Image:	ImageStreamTag openshift/nodejs:10
Output to:	ImageStreamTag case-02299469:latest

Build Run Policy:	Serial
Triggered by:		ImageChange, Config
Webhook Generic:
	URL:		https://qe-hongli-311-master-etcd-1:8443/apis/build.openshift.io/v1/namespaces/yapei12/buildconfigs/case-02299469/webhooks/<secret>/generic
	AllowEnv:	false
Webhook GitHub:
	URL:	https://qe-hongli-311-master-etcd-1:8443/apis/build.openshift.io/v1/namespaces/yapei12/buildconfigs/case-02299469/webhooks/<secret>/github
Builds History Limit:
	Successful:	5
	Failed:		5

Build			Status	Duration		Creation Time
case-02299469-1 	new 	waiting for 26s 	2019-02-24 20:52:47 -0500 EST

Events:	<none>
2. Goes to Builds -> Builds -> case-02299469 -> Actions -> Edit -> change source repo and add environment variables -> Save
the changes are also saved successfully, recording here http://g.recordit.co/IIJvoGwefp.gif

Since the reported issues are not reproduced on the version includes the fix, I will move the bug to VERIFIED.

Feel free the reopen if there's other concern.

Comment 12 Yadan Pei 2019-02-25 02:00:57 UTC
Verifed on openshift v3.11.87

[yapei@dhcp-140-3 origin-web-console-server]$ git log atomic-openshift-web-console-3.11.87-1 -1
commit cb202eb5a52400dd5c995503a600c521c3b6b35a (tag: atomic-openshift-web-console-3.11.87-1)
Author: AOS Automation Release Team <aos-team-art@redhat.com>
Date:   Wed Feb 20 08:27:13 2019 -0500

    bump origin-web-console 01417905

[yapei@dhcp-140-3 origin-web-console]$ git log --pretty="%h %cd - %s" 01417905 | grep '#3117'
01417905 Mon Feb 11 21:47:01 2019 +0100 - Merge pull request #3117 from jhadvig/3.11.bc-bug

Comment 14 errata-xmlrpc 2019-04-11 05:38:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0636


Note You need to log in before you can comment on or make changes to this bug.